Support Website Contact Support Blog

Drone fails to follow route Pix4D

Tried using my phantom 3 pro drone with Pix4D and followed the instructions carefully. I specified a route and the checklist is green. The drone takes off to the right altitude but instead of going to the first waypoint the drone just stays stationary even after 5 minutes. In the end I have to manually land the drone. Tried 3 times and restarting the app and created 3 new routes. The drone is within  the green bounding box. The drone has the latest firmware.

Ive had the same issue with my P4

Hi James and Mark,

What is the version of Pix4Dcapture you are using? Did you still encounter that problem with the latest versions we have released last week?

We are aware of some issues with the latest DJI firmware. As one of them, for each new mission, the height limitation is reset to 50 or 100 m meaning that if the altitude of the mission is higher, the drone will not start it. The user should then check that setting in the DJI GO app. We are not sure to fully understand the problem but it might come from that.

Regards,