Support Website Contact Support Blog

Phantom 4 Pro Mission Failure - Hovering

Our company has recently purchased a second (factory refurbished) P4 Pro. Our first worked well for many flights until an unexpected loss of power on descent at the end of a Pix4d mission; It is currently being repaired. Our second P4 has only successfully completed a mission once, after several tries and on different days and locations. In some instances the aircraft gets to the start point and remains hovering there, in other cases it completes one row of photos and remains at the end of the first grid line. It also does not travel to the start point in a straight line (the one successful mission did), and in one instance it overshot the start point, then turned around to get back to it. In some cases precision landing functions as it should, but in other cases it lands several feet from the launch site. Initial setup of the P4 Pro included an update to firmware 1.05.06 as well as the usual compass and IMU calibration. Compass and IMU calibrations were re-done several times with no change to the aircraft’s actions on the missions.

At this point we need to know if these issues are due to a failure with an aircraft hardware component, or if they are software/SDK issues. Without a second P4 on the same firmware it is not possible to do any further testing. We have also tried a second capture app (Precision Flight) and it produced the same hovering issue after completing one line of photos. DJIGo4 does not give any warnings of interference, and compasses/IMU appear within the normal values for all of our flights. Satellite numbers were normal during each flight.

We are using the latest Android version of Pix4d, on a Lenovo Tab4 with Android 7.

Any help on this issue would be appreciated.

No help here but I am experiencing the exact same issues with my P4 Pro. It has worked well for the past 3 months up until last week and started doing exactly as you have described. My drone has also indicated it was going to land after only the first row of photos and left the mission to land but never actually landed, just continued to fly off until I manually took control and brought it back down.

Interested to know your findings about this. I am flying the drone with the latest Pix4d Capture app on my Iphone 8 plus.

 

We consulted DJI tech support to discuss any known issues.  They stated that they are familiar with the symptoms and advise IMU and compass re-calibration.  They also agreed that we could refresh our firmware.

We elected to downgrade from 1.05.06 to 1.05.03 and re-calibrated IMU and compass.  We flew a short test mission at the office using PIX4d Capture which executed normally, including precision landing.

We will fly additional missions in the next few days though.

Great to know. Thanks. That was going to be my next step. I upgraded to the 1.05.06 last week and that’s when the trouble started. My new back up drone has not been updated and it works fine on the same app.