Support Website Contact Support Blog

My Drone DJI Phantom 4 Pro V2 only Hover approximately 3 meters

hello friends. DJI Pahntom 4 Pro V2 is not flying base on the mission, even though the check list for take off is complete, only hover 4meters. i am using App Pix4D Capture to create the mission. i am already to do calibrate compass and IMU, but the problem is not solved.

1 Like

I have had this happen a number of times.
I found that it was often an object , such as a roofline or tree was affecting the obstacle avoidance.
I would just use the controls to move the drone away from objects and away it would fly and complete the mission

1 Like

Same issue here…Went through all the checks, verified no firmware update was needed to either the drone or the remote, but just hovers 5-6 ft off the ground. I tried what others in the forum had suggested about letting it hover for a minute or so, but no luck. No app updates either…Any other ideas?

Hello,

I would suggest you go through all the basic checks and troubleshooting steps as well as the Pix4Dcapture troubleshooter as it may resolve most of the issues that can be encountered, if properly followed. Check also if the issue also happens when you select the GRID mission plan or other plans as well.

Best,
Nikoleta