Support Website Contact Support Blog

DJI SDK error The server may be busy or is not reachable

Hi, i have an issue for connecting my drone (phantom 3 pro) to ctrl+dji. It cannot connect and always say DJI SDK error the server my be busy or is not reachable.

Is anyone have some issue like me?

By the way i use android samsung galaxy m30s



In a first time, as this behavior was not reported to us so far. I would suggest going all along the basic checks and troubleshooting steps described on our article online.

I would especially check the following steps to be able to connect to your drone.
Also, you can try unistalling both applications and reinstalling them if the issue is not solved.
Note that to be able to run properly Pix4Dcapture, you need to run Android V7.0 or above on your mobile device.

Best regards,

Hello Gael!
I’m experiencing exactly the same issue. I have followed troubleshooting steps and the error persist.
I’m using Samsung S8, Android V9
Drone Phantom 3 Stantandard. Firmware Updated.

I’ve tried with another Samsung S8 and I’ve experienced the same issue.
Would you be so kindly to let me know how could I sort out this error, please?

In both phones first time I run the app Ctrl+DJI I got the following message: “DJI SDK error: the server may be busy or is not reachable”.
The message showup just only once, first time after installing it; never happened again closing the app (force close) and opening again.
Then the Ctrl+DJI never connect to the drone and from time to time show up a message: “Ctrl+DJI continue failling”.
From Pix4D Capture by clisking in “start” request “connect to drone”.

Thanks in advance!

Tengo el mismo problema, he seguido las instrucciones y el problema persiste. Tengo un P4Pro, y mi smartphone es un Huawei P30 Lite con vercion Android 9.0

Yesterday I’ve tried with another mobile phone, Samsung J5 Prime (Model: SM-G570M) and I’ve experienced the same issue.

I hope you could provide me a proper solution soon, I’m very interested to test your solution.

As a first step, I would suggest you go through all the basic checks and troubleshooting steps as it will solve most of the issues that can be encountered if properly followed.

In a second time, I would suggest reinstalling the applications from scratch following the procedure below:


The two procedures below may imply data loss so we recommend to make a backup if there are important data saved. Connect the mobile device and copy the Pix4D folder (Local Storage > Device storage > Pix4D) to your computer.

  1. Clear data and clear cache memory of the application

  2. Open the Settings application on the Android device.2. Scroll the list and tap Apps, Applications or Manage apps.

  3. (optional) On certain devices like Samsung, tap Application Manager.

  4. Scroll the list to find the application.

  5. From the list, tap Storage.


  7. Re-install Ctrl+Plugin and Pix4Dcapture from scratch

  8. Uninstall Pix4Dcapture and Ctrl+Plugin.

  9. Connect the device to a computer and navigate to Local Storage > Device storage > Pix4D.

  10. Delete the content of all folders.

  11. Delete the Pix4D folder.

  12. Re-install the latest version of Pix4Dcapture and Ctrl+Plugin.

  13. (optional) Place the backup content back into the Pix4D folder to restore data.


Thanks Kapil for your feedback!
I’ll follow your instructions and provide you a feedback asap!


Hello Kapil!
I’ve followed both procedures you’ve provided me and unfortunately it didn’t works.
Ctrl+DJI didn’t connect with my Phantom 3 Standard. Just once show me the message: “DJI SDK error: The server may be busy or is not reachable”.
Do you’ve any other suggestion?


Hi I am having the exact same problem with my Phantom 4 Pro connecting to a Samsung S8.

This is the first time since I have attempted to connect since the last Android update.

Even DJI GO4 wont connect.

I have uninstalled all apps and reinstalled. I can connect DJI GO4, however when I then attempt Pix4D capture wont connect, and then DJI GO4 will also no longer connect.

I suspect there is an issue between the DJI CTRL+ and the most recent version of Android.

Hello Kapil!
Would you be so kindly to provide me your feedback, please?


HI Kapil,

I am also facing the same issue since two days, followed all the steps you suggested still the problem continues … can you pls suggest whats to be done asap…

Thanks in advance…

Hi, I am also facing the same problem too. Cannot connect to Ctrl+Dji also.

Hi team

We downgraded both the ctrl+plugin n Pix4Dcapture Versions and were able to fly and capture images … there is some signal loss issues in between else everything was smooth …

1 Like

Hello Developer_XYZ, would you be son kindly to explain me how may I downgraded both app, please?
Actually, I’ve deleted both from my mobile, due here are not providing any support and I was testing other apps.
Thanks in advance!

P.S.: Pix4D Support Team, if you have some minutes to provide us a feedback, we will be very thankful.


Please share your email id … I will share you the apk’s …

1 Like

Hey! Here you’ve my emails address:;
Thank you very much!


Hi, Developer_XYZ , i have they same issue, would you be si kindly and share with me they apk’s? Thanks in advance. My email is

I’ve followed both procedures and unfortunately it didn’t works.
My Redmi 6 provided this notification:

“java.lang.SecurityException: com.pix4d.plugindji was not granted either of these permissions: android.permission.CHANGE_NETWORK_STATE, android.permission.WRITE_SETTINGS.
at android.os.Parcel.createException(
at android.os.Parcel.readException(
at android.os.Parcel.readException(
at dji.midware.wifi.DJIMultiNetworkMgr.g(Unknown Source:192)
at dji.midware.wifi.DJIMultiNetworkMgr.a(Unknown Source:85)
at dji.midware.broadcastReceivers.DJINetWorkReceiver.(Unknown Source:7)
at dji.sdk.sdkmanager.DJISDKManager.initParams(Unknown Source:164)
at dji.sdk.sdkmanager.DJISDKManager.initSDKManager(Unknown Source:253)
at dji.sdk.sdkmanager.DJISDKManager.registerApp(Unknown Source:45)
at dji.sdk.sdkmanager.DJISDKManager.access$600(Unknown Source:0)
at dji.sdk.sdkmanager.DJISDKManager$5$1.onDownloadSuccess(Unknown Source:6)
at dji.internal.flysafe.DJIFlySafeDBLoader.a(Unknown Source:19)
at dji.sdk.sdkmanager.DJISDKManager$ Source:33)
at dji.sdksharedlib.util.DJISDKCacheThreadManager$ Source:5)
at java.util.concurrent.ThreadPoolExecutor.runWorker(
at java.util.concurrent.ThreadPoolExecutor$
Caused by: android.os.RemoteException: Remote stack trace:
at android.provider.Settings.isCallingPackageAllowedToPerformAppOpsProtectedOperation(
at android.provider.Settings.checkAndNoteChangeNetworkStateOperation(

I have the same problem. I followed all the steps described to fix it, but it persists. I have a Mavic 2 Pro and a Galaxy Tab S3 with Android 9. Is there another solution?