Support Website Contact Support Blog

Ctrl+dji not compatible

Hi. My samsung SM-T561 is not compatible with ctrl+dji app. all software is up to date on my Samsung Tablet. Will I still be able to use this tablet and fly a mission with Pix4D Capture?

Hi Byron,

in order to be able to fly the mission with the Android version both apps, Pix4Dcapture and Ctrl+DJI, need to be installed on the device. 

At the moment there are no other users reporting the same issue and it might be something specific to the device you are using which can actually be incompatible in the end.  

Could you try to try the following procedures in order to see if it resolves the issue:

Method 1: Clear Cache and Data of Google Play Store:

  • Go to Settings.
  • Click on Apps or Application Manager option.
  • Now, swipe right further to open All tab.
  • Now, scroll down and look for Google Play Store app. Click on it.
  • Here, you will see two buttons – 1. Clear Cache and 2. Clear Data. Click on them.

Method 2: Reconfigure your Google Account:

  • Go to Settings.
  • Click on Google option under Accounts Section.
  • Now, click on your Google account and select Remove Account option.
  • Now, restart your android phone and reconfigure your Google Account.

Best,

Hi!

I have the same issue with my tablet SM-T320, it is said that the device is not compatible with Ctrl-Dji, so I can’t fly with it. Did Pix4D fixed this problem?

I had restored my tablet and nothing. 

Thanks in advance. 

 

@Maite, I would recommend making sure that the device you are using runs the Android version 5.0 (minimum requirement) or higher.

Updating the device or using another device should solve the compatibility issue. 

Exactly! After writing here, I discovered that point. My tablet runs Android 4.2 and it is impossible (at least for me) to update it, so the app is not compatible with my device. 

Thanks for your help.

Maite.

Hello. Can you provide the latest version which still worked on android 4.4? 1.8.1 appears to be the last

Pix4dCapture keeps asking to upgrade Ctrl-DJI but I can’t upgrade because it is no longer compatible with my Android 4.4 device .

@Alonso, we always recommend using the latest versions of the apps in order to be sure that all the latest improvements and bug fixes are included. Also, some recent changes, like GDPR, do not allow us to provide the previous versions. Thank you for understanding.