CTRL+DJI crashes on MIUI Global 13.0.2

Hi there,
I’ve a Redmi Note 11 Pro 5G, and in August I updated it to MIUI Global 13.0.2; since then, some apps like DJI Go 4 and Telcel stopped to work: the first one was crashing instantaneously, while the second one stayed stuck on the home page.
Because for a while I stopped to plan flight, I didn’t notice if also CTRL+DJI had issues, but today I can confirm: despite Pix4D Capture is opening fine, CTRL+DJI crashes immediately.
So I’m interested to know if:

  • other users have experiencing the same issue
  • Pix4D will release a fix for CTRL+DJI as soon as possible, because I’m still not so experienced as to manually fly a Phantom 4 with DJI Go 4 and auto-shutter enabled, simulating the fixed path I would designed with Pix4D Capture.

About DJI Go 4, they solved the issue with a new release, sent via private message during the beta test, and officially shared when stable: if Pix4D IT Team is planning to do something similar, I would appreciate to be part of the beta test.

Well, I will self-reply :sweat_smile:

"The latest version of Ctrl+DJI (1.9.9) available on the Google Play Store is not compatible with devices running the Android 12 operating system. Install the Ctrl+DJI 1.9.10 beta version using the below link: https://s3.us-east-2.amazonaws.com/mobile-pix4d-releases.pix4d.com/capture/android/4.11.1(3060)/ctrl_dji_1.9.10.apk

1 Like