Can not "start" the project under Pix4Dmatic

Hey,

After I import my dataset and new a new project, I found the “start” button is always dark. I do not know why. Then I download the example dataset “Pix4Dmatic_example_100_images” from your website. I import them as usual, it can be started easily, with a blue “start”. You can see the screenshot as following,


Could you help to check what happens to my own dataset, please?

I also attached several RGB images taken by my drone to help your check (OneDrive link).
https://stuecnueducn-my.sharepoint.com/:u:/g/personal/52173904027_stu_ecnu_edu_cn/EfzE-H6VqrNPi_vMd84YHyYBPxVZqs4tvfKRmwLbG7vufw?e=h87eqc

If you need a larger dataset (such as hundred images), please let me know, thanks.

Best
Yalei

Hi Yalei,

Thanks for sharing the images with us.
I tried to also import them but it looks like the Image geolocation and orientation metadata are missing:

[2022-04-19 12:06:04][00%CPU][61%RAM]Add 5 image(s) 5 image(s) added
[2022-04-19 12:06:04][00%CPU][61%RAM]Add 5 image(s) Adding 5 image(s)
Image orientation metadata missing

PIX4Dmatic can process images captured by practically any camera as long as the images contain the necessary EXIF/XMP (metadata) tags.

If image geolocation and orientation (yaw, pitch, roll) are not written in the images’ metadata, it is possible to import the information with either a .txt or .csv file. To import the image geolocation and orientation with a .csv or .txt file, please see the Image geolocation and orientation import format article.

I hope this answers your question.

Best,

Hey
Thanks very much for your kind reply.
In fact, they contain the GPS information (latitude, longitude, altitude), you could check it from the Properties of each image. Is it strictly necessary to contain the yaw, pitch, roll, please? When I process them in Pix4D, the yaw, pitch, roll is not necessary.

In my project, all the GPS information was from ppk via RTKLIB. The output pos data (tags) had a header as the format “% GPST, latitude(deg), longitude(deg), height(m), Q, ns, sdn(m), sde(m), sdu(m), sdne(m), sdeu(m), sdun(m), age(s), ratio”
Do you know how I can pick the yaw, pitch, roll information from it, please?

Hi Yalei,

As I mentioned in my previous message PIX4Dmatic can process images captured by practically any camera as long as the images contain the necessary EXIF/XMP (metadata) tags.

For the precalibrated camera models the image geolocation and orientation (yaw, pitch, roll) file is not needed, but if the camera model used does not belong on the list of the precalibrated cameras, then you will have to import the information with either a .txt or .csv file. Usually the yaw, pitch, roll values are given by the manufacturer. You could contact them for further information.

Best,

Hey Nikoleta,

Thanks very much for your detailed answer! I guess I need to contact the manufacturer for further information.

Have a nice day!
Yalei

Hi Yalei,

I agree that this is the best way to proceed.
If you have any questions let us know.

Have a great day!

Best,

Hi,

I have the same problem, the “Start” button is not available. I have images taken while Phoenix Lidar Ranger Ultra laser scanner data acquisition, the camera integrated is Sony Alpha 6000 and the orientations are available as the system has high grade IMU unit.

I imported the geotag file, (filename,lat,long,height,yaw,pitch,roll) which can be exported from Spatial Explorer:
image

The geotag file as an attachment:
geotag_test.txt (36.3 KB)

Have been using Pix4Dmapper with no problems, but now have big ortho projects coming so thought Pix4Dmatic would be better.

I’m bit in a hurry, so would appreciate any help!
Thanks!

Hi @heikki.hakkila

I tried to emulate the import with two images and it seems to work.
Do you have any error or warning messages in the status center in PIX4Dmatic?
That’s the bar in the bottom of the interface. This might help us understand what the issue is.

Also, could you please share an example image? or maybe 2-3, that way I try to reproduce it with your data directly.

Cheers

Hi, thanks for the very fast response!
Here you can download the four first images:

And no errors in the status center.

Hi, thanks for sharing a few images.

Can you please detail which steps you take when you import the images and the geotags file?

I am surprised there is nothing in the status center, can you please share a screenshot? Here is what I get when I import the 4 images with the entire file and then I import the 4 images with the geotags adjusted to have only 4.

I need to check whether we handle the case of importing a file that has geotags for more images than the ones that were imported correctly, this one seems to gray out the “Start” button.

But when there is the right images and the corresponding tags, it seems to work. Note: there seems to be a tilt in the orientation when it calibrates, something to check once you could import everything.

1 Like

Hi, thank you very much, this solved the case!

I tested a bit around, and it seems, that:
Ii you import let’s say 100 images and the geotags only for 95 of them, it will gray out the “Start” button. But if you import 100 images and geotag file which includes them and some more, it will work.

I think in Pix4Dmapper you were able to import x amount of images and then the geotags only for those you need, and it still worked with no issue.

So now it’s better to check that your image files and geotag file are 100% corresponding.
That’s no problem, just have to remember that.

And yes, I got those same errors as you when I finally found the status bar from my huge screen :smiley:

Thank you once more!

ps. You are right, something is wrong with the orientation, should be nadir looking images.
Have to check that.

Hi @heikki.hakkila , glad to hear it worked out! and that you found the status center too! :sweat_smile: it’s going to be useful!

I logged a bug report about the issue you encountered, we’ll look into fixing this.

Cheers,
Pierangelo

1 Like

@heikki.hakkila quick question, it is very well possible that it is actually working and that the workaround we discussed is not necessary. The “Start” button is always grayed out if no processing step is selected. Can you please try again to reproduce the initial issue and ensure that you selected a processing step such as “Calibrate”? It’s possible I tested this a little too quickly last time.

Here is an example (on my computer I can’t reproduce the issue anymore):

Sorry, just noticed this recently. But yes, the case was not that any step was not selected.
I once more tried things with a few images

  1. If you import more images than geotags —> button is grayed

  2. If you import more geotags than images —> button works fine (even though it gives some warning notice when importing geotags)

image

Hi @heikki.hakkila ,

May I ask if this image is taken when you import more images than geotags?

Best,

Hi @Nikoleta_Dimopoulou

The screenshot provided on my previous post is taken after I first imported 3 images and then 4 geotags.
So there was one extra geotag and it gave a warning about that.

Hi @heikki.hakkila ,

Thanks a lot for the information. I assume that after importing more geotags than the images you are able to process.

Best,

Yes, after importing more geotags than images the processing started ok.

Hi,

Thanks a lot for the feedback and we are glad you were able to start processing!
Have a great day!

Best,