Support Website Contact Support Blog

Camera, Sun Irradiance and Sun angle in red text

Hi,

In the image processing (Index Calculator Tab), I cannot process with correction type: Camera, Sun Irradiance and Sun Angle. It shows in red text. and error log:

[Error]: IMG\_170223\_060720\_0562\_GRE.TIF: No sun sensor pose information

[Error]: IMG\_170223\_060721\_0563\_GRE.TIF: No sun sensor pose information

[Error]: IMG\_170223\_060723\_0565\_GRE.TIF: No sun sensor pose information

I have found a similar post (Sequoia sun angle correction), but I am using Disco Pro Ag (Parrot) and Sequoia sensors.

Could you please explain how to fix the sun angle error?

Thanks,

Siline

This error in enabling sun angle correction might be due to a previous version of the drone and camera firmware. Could you do the following steps :

  • update the Disco Pro Ag firmware to 1.5.2
  • update the Sequoia firmware to 1.4.1

With these updates, the Sequoia images should have in exif the tag “Xmp.Camera.IrradianceRelativeRotation” set to {173, 0, 0}. With this tag, the mapper can compute the desired correction.

Thank very much Marc.

It is mean that I need to fly again right?

Or Is there any way to do manually to add tag “Xmp.Camera.IrradianceRelativeRotation” set to {173, 0, 0}

Dear Siline,

You don’t have to fly again but be aware that you will need to tag the images to compute the correction type “Camera, Sun Irradiance and Sun Angle”.

You can use exiv2 program to write exiv tags in your images. To manually set the tag in your images stored in a folder working_directory, please run these two commands in bash script:

  • cd working_directory
  • exiv2 “-Mreg Camera http://pix4d.com/camera/1.0/” “-Mset Xmp.Camera.IrradianceRelativeRotation  173, 0, 0” *.TIF

Please, be aware that for Windows, the basic command prompt doesn’t allow to walk through all the folder using *.TIF. You will need to use bash script.

Best regards,

1 Like

Thank you.

installing exiv2 on my windows7 is a challenge for me.

Therefore, I use exiftool instead. by using user defined tag

%Image::ExifTool::UserDefined = (
    ‘Image::ExifTool::XMP::xmp’ => {
       
       IrradianceRelativeRotation => { Writable => ‘lang-alt’ },
        
    },
);

exiftool -config “c:\con.config” -xmp-xmp:IrradianceRelativeRotation=“173, 0, 0” “C:\workingspace*.tif”

I got this metadata:

However, the correction type “Camera, Sun Irradiance and Sun Angle” is still in the red text.

and with these errors:

[UI]: Processing Options clicked.

[Error]: Error e9035a: camera model name: Sequoia\_4.0\_1280x960 (Green)(1), correction type: sunIrradianceAndAngleWithPoseFromCamera - Missing information for radiometric correction in 7/29 images:

[Error]: IMG\_170223\_055908\_0070\_GRE.TIF: No sun sensor pose information

[Error]: IMG\_170223\_055912\_0074\_GRE.TIF: No sun sensor pose information

[Error]: IMG\_170223\_055911\_0073\_GRE.TIF: No sun sensor pose information

[Error]: IMG\_170223\_055910\_0072\_GRE.TIF: No sun sensor pose information

[Error]: IMG\_170223\_055909\_0071\_GRE.TIF: No sun sensor pose information

[Error]: IMG\_170223\_055914\_0076\_GRE.TIF: No sun sensor pose information

[Error]: IMG\_170223\_055913\_0075\_GRE.TIF: No sun sensor pose information

[Error]: 

Best Regards

Siline

Can you please share the images that you have modified (as well as the unmodified images) on this link. We will have a look

https://www.dropbox.com/request/VDKg4wzBQ2waxzVWN5NL

Regards

Hi Marc, I have dropped the iamges into ur box. 

Thanks

Siline

Dear Siline,

Please find below how it is written right now, with the correction you made in the exif, and how it should be written.


The writable option should be “XmpText” and the tag should be Xmp. Camera.IrradianceRelativeRotation.

As soon as those two items are set, the sun sensor pose should be recognized by Pix4D Mapper.

Best Regards,

Hi Manuel,

I tried this, but it does not work.

%Image::ExifTool::UserDefined = (
    ‘Image::ExifTool::XMP::Xmp’ => {
       
       Camera.IrradianceRelativeRotation => { Writable => ‘XmpText’ },
        
    },
);

Could you please past me your exif script?

Thanks

Siline

Basic question here…how does this “error” actually affect processing in time, quality, or accuracy of the matches and/or point cloud?

Hi Adam,

The error is in during processing time.

 

Hi,

I have a similar issue with pix4d mapper 3.2.17 when i try to add sun angle corrections. The log panel show me these messages for each spectral bands:

So i checked with Exiftool the IrradianceRelativeRotation tag. It has a value of ‘175,0,0’ so it is well informed in the image exifs.

There is another way to fix this error ?

Thanks

Thomas, can you send me some images? You can upload in dropbox or google drive and share the link here. I want to check if it works with the latest version and also the exif of the images to see why this is happening

Of course, this is a link to download a sample of my dataset: https://we.tl/t-oN1Dc6BMnc

Thanks

Thomas, the tag in your images is irradianceRelativeOrientation, should be rotation instead of orientation. Did you edit the tags?

1 Like

No, actually I didn’t edit the tag. Is there an easy way to do it with Windows10 ?

Finally I managed to edit the tags with Exiftool. The following command line is used with Linux to add the tag :

exiftool -overwrite_original -config “/home/****/.ExifTool_config” -IrradianceRelativeRotation=“175,0,0” /home/****/data/*.TIF

The file “.ExifTool_config” is edited as follows:

%Image::ExifTool::UserDefined = (
# All EXIF tags are added to the Main table, and WriteGroup is used to
# specify where the tag is written (default is ExifIFD if not specified):
    ‘Image::ExifTool::XMP::Main’ => {
       Camera => {
          SubDirectory => {
             TagTable => ‘Image::ExifTool::UserDefined::Camera’,
          },
       },
    },
);

%Image::ExifTool::UserDefined::Camera = (
    GROUPS => { 0 => ‘XMP’, 1 => ‘XMP-Camera’, 2 => ‘Camera’ },
    NAMESPACE => { ‘Camera’ => ‘http://pix4d.com/camera/1.0/’ },
    WRITABLE => ‘string’, # (default to string-type tags)
    IrradianceRelativeRotation => { },
);

Thanks @Momtanu for your help.

That’s great Thomas! Thank you for the update :slight_smile: I assume you could use sun angle calibration after the edit?

Yes exactly !

1 Like

I would just correct two errors in the command line :

exiftool -config “/home/user/.ExifTool_config” -overwrite_original -IrradianceRelativeRotation=175,0,0 /home/user/data/*.TIF