Support Website Contact Support Blog

Bad axis orientation in RayCloud

Hello,

I have a strange problem with one of my image processing: the axis orientation in RayCloud is not correct (the Z axis is parallel to the images and the Y is perpendicular), which produce really bad results (like the top is actually the side of the images).
Images have no geoloc but good overlap.

Here is a link to some images and the quality report to visualise what I tried to explain:
https://www.dropbox.com/sh/1j1o8iggmabfbgv/AACzB3g0aVKYwA91a5fotDaia?dl=0
In ray cloud the result is also very “curvy”, is it possible to avoid that (without geoloc)?

It the first time I have such a bad result. Any idea ? I would like to avoid using geoloc (technical reasons).

Thank you.
Best Regards, Benjamin

Hello Benjamin,

This issue may come if the images have no geolocation and there are no GCPs.

There are several possible solutions:
Add manual tiepoints and reoptimize:
https://support.pix4d.com/hc/en-us/articles/202561199

Add GCPs (real or fake GCPs) and reoptimize:
https://support.pix4d.com/hc/en-us/articles/202560239

Regards,

Dear,

I’ve got the same kind of problems with projects. Although, I’ve inserted lots of GCP’s

The snake is eating it’s tail. 

Also, I’ve tried to decompose the project in sub projects (only have GCP’s on a straight line then) + I added axis constraints but the pictures still appear looking sideways instead of nadir. 

(project is a DSLR mounted on a 3 meter high trolley taking detailed pictures of a road inside a tunnel (so no gps = no drone possibilities) 

In the decomposed subproject, I’ve given an estimated position of the cameras for one row + 2 axis constraints + 4 gcps. 

Any suggestions on how to proceed? 

Hello,

It would be good to have a look at the Quality Report.

Anyway, I would say that the problem might be the lack of automatic tie points. I guess that the tunnel does not have much texture and the software cannot find many.

I do not know what processing options you are using, but I would try with a large Image Scale in Step1, maybe 1/2 or even 1/4 or 1/8 in case it still fails. I would also enablegeometrically verified matching.

I hope these tips help you.

Regards.