Wrong camera orientation

Hi group. I’m just starting out with Pix4D mapper and have run into a snag.
I recently completed a survey and 6 of my camera shots, out of 877, are shown at a goofy angle.

Is there a way to edit the camera angle back to the horizontal?

I know I can disable them and reprocess, but I would like to be able to edit them as well and make them correct.
Very much appreciated.

Hi @sid,

Thank you for your message and welcome to the Pix4D Community :slight_smile:.

From the image capture you shared, it seems that all the images are taken with nadir orientation. Could you eventually show me the wrong camera orientations from another angle of the rayCloud?

I can see that there are some artifacts in the back of your projects. Please add some Manual Tie Points (MTPs) in this region:

If you are still getting errors after using MTPs, please share with us the Quality Report in pdf format.
If you can’t share the report publicly, feel free to open a support ticket here:


I believe I have a similar issue with a rotated ray-cloud. Coordinate systems match, I have 8 GCPS. Quality report uploaded as well. Please help.
100017937_Ortho_report.pdf (421.0 KB)

Hi @bverolla,

Welcome to the Pix4D Community :slight_smile:.

Thank you for sharing your quality report.
It seems that the images were “rotated” because the GCPs coordinates are incorrect.
Could it be possible to open a support ticket with us where you share about 5 to 10 images (where GCP targets are visible), the GCPs file, and your .p4d file?

You can open a support ticket here:


I did Daniele thank you, here is the Request #123456

Thanks Daniele.
Yes, I had a few other views, but me being a new user, the forum would only let me post one image per post.
Here is another one.

I have not tried the GCP’s or MTP’s as yet, but plan to shortly. I hope that will correct the issue.


Hi @sid,

Thank you for the additional image. I can see the issue now.

Yes, please try adding some Manual Tie Points (MTPs) and let me know.
If possible, please provide me the quality report, I will then be able to see the settings you used.

You can already try, however, to change the Calibration Internal Parameters Optimization to All prior (https://support.pix4d.com/hc/en-us/articles/205327965-Menu-Process-Processing-Options-1-Initial-Processing-Calibration#label2)

Please let me know how it goes.