Support Website Contact Support Blog

Rotated sections of the cloud

Is there a way to limit the camera angles that PIX4D can select as solutions to what it sees. We are flying long sections of land, for example one mile long. Often after initial processing one section of the cloud will be upside down, and another section at 90 degrees with other sections flat on the ground.

Since we are flying from above on relatively flat ground it would be good to tell the program at the very least assume everything is below the level of the “camera” geolocation and generally in the X and Y plane.

We can fix these issues by adding tie points, etc and pulling it all back down. But it would be nice to be able to initially restrict the camera to give better initial results.

Hi Curtis,

This issue may come if flying on only one line or when using images with no geolocation and no GCPs, it can be solved by adding GCPs, please check:

https://support.pix4d.com/hc/en-us/articles/202561209

Regards,

We use multiple lines, Geolocation and GCPs. But the clouds can often still twist. Limiting the options on the camera rotation in initial processing would seem to reduce this problem. If the program tries to rotate the camera more than so many degrees off of the XY plane it will know that solution is not correct, try a different solution.

It is a form of solution filter.

Hi Curtis,

In that case we will need to investigate in detail since it may be related to multiple factors.

Please provide us the project images, project log file, .p4d file and quality report following:

https://support.pix4d.com/hc/en-us/articles/202558589

And let us know once it is uploaded, so we can investigate in detail,

Regards,

The same thing happens to us (me). I am trying out Pix4D in a trial and we also get groups of cloud points that are ‘underground’ or rotated at an odd angle. It’s as if Pix4D gets the majority of the camera shots pieced together properly, but then 2, 3 or 4 camera shots get pieced togther by themselves as a separate group but don’t get placed in the overall location properly.
So, how can I prevent this from happening or, how do I fix it? Curtis, you mentioned being able to “pull it back down” but I’m curious how you are doing that. Excuse my ‘newbiness’ but I’m on a seven day trial… Thanks.

You “pull it back down” with some kind of tie point or ground control. Basically to give it a known location it can reference from. Your description of clusters taking sections of the cloud off, sounds like you need to “uncalibrate” the photos that are at odd angles, then create tie points that show up in photos that are calibrated at the correct angle and also show up in the photos that tend to calibrate incorrectly. Depending on your subject, this might be the corner of a rock, corner of a window or end of a paint line. Something very distinctive and with good contrast. It is best if the point you select looks the same in all or most of the photos in question.

Applying control and other constraints after initial processing helps to decreased time in following processing chain.

In version 2.0.77 however cloud construction seems to have improved for me over previous version releases.

P.S. Hi Curtis from 1970s heliboy/baron-30 days!

My pain too, I have tried everything including trying to rematch and reoptimize, to no success. Whihc angle of roatation is responsible for this mishap, Omega,Phi or Kappa? Anyone??

 

 

As can be seen from the above images, the GCPs are all in their rightful places. The images are however all upside down and it has been impossible for me to fix.

Hi Flo,

Could you try to run the project with the settings Accurate Geolocation and Orientation for the Calibration Method of step 1 (learn more)? Also did you try to mark the GCPs in the images using the rayCloud (learn more) or the Basic Editor (learn more) to see if changes the orientation?