Support Website Contact Support Blog

3D model losing texture quality

After processing out a small scene that had over 900 cameras, the 3D mesh seems like it’s losing it’s texture quality, especially in the trees. The dense cloud seems fine, but as soon as I view the textured 3d model without the dense cloud it all turns brown and overly-bulbous. Is there a way to not have the “feathering” in the texture so that it doesn’t bleed into the resulting mesh? I’d prefer to have more holes in my model than to have a poorly textured model that’s bulbous. Thanks!

 

Above: Dense cloud with correct pixel coloring in trees.

 

Above: Dense cloud and mesh.

 


Above: Mesh only, trees appearing brown.
 

 

Above: Texture example with “feathering” around edges of the pieces. No green existed in any of the four texture tiles that were generated.

 

 

***Here were my settings:

Initial Processing Details

info

System Information

info
Hardware CPU: Intel® Xeon® CPU E5-1650 0 @ 3.20GHz
RAM: 64GB
GPU: NVIDIA Quadro P2000 (Driver: 22.21.13.8476)
Operating System Windows 10 Pro, 64-bit

Coordinate Systems

info
Image Coordinate System WGS84 (egm96)
Ground Control Point (GCP) Coordinate System NAD_1983_StatePlane_Idaho_West_FIPS_1103_Feet (egm96)
Output Coordinate System NAD_1983_StatePlane_Idaho_West_FIPS_1103_Feet (egm96)

Processing Options

info
Detected Template No Template Available
Keypoints Image Scale Full, Image Scale: 1
Advanced: Matching Image Pairs Aerial Grid or Corridor
Advanced: Matching Strategy Use Geometrically Verified Matching: no
Advanced: Keypoint Extraction Targeted Number of Keypoints: Automatic
Advanced: Calibration Calibration Method: Standard
Internal Parameters Optimization: All
External Parameters Optimization: All
Rematch: Auto, no

Point Cloud Densification details

info

Processing Options

info
Image Scale multiscale, 1/2 (Half image size, Default)
Point Density Optimal
Minimum Number of Matches 3
3D Textured Mesh Generation yes
3D Textured Mesh Settings: Resolution: High Resolution
Color Balancing: yes
LOD Generated: no
Advanced: 3D Textured Mesh Settings Sample Density Divider: 1
Advanced: Image Groups group1
Advanced: Use Processing Area no
Advanced: Use Annotations yes
Time for Point Cloud Densification 11h:52m:55s
Time for Point Cloud Classification NA
Time for 3D Textured Mesh Generation 02h:38m:30s

Results

info
Number of Processed Clusters 2
Number of Generated Tiles 3
Number of 3D Densified Points 60292489
Average Density (per ft3) 76.33

DSM, Orthomosaic and Index Details

info

Processing Options

info
DSM and Orthomosaic Resolution 1 x GSD (1.12 [cm/pixel])
DSM Filters Noise Filtering: yes
Surface Smoothing: yes, Type: Medium
Orthomosaic Generated: yes
Merge Tiles: yes
GeoTIFF Without Transparency: no
Google Maps Tiles and KML: no
Raster DTM Generated: yes
Merge Tiles: yes
DTM Resolution 5 x GSD (1.12 [cm/pixel])
Time for DSM Generation 00s
Time for Orthomosaic Generation 01h:38m:06s
Time for DTM Generation 00s
Time for Contour Lines Generation 00s
Time for Reflectance Map Generation 00s
Time for Index Map Generation 00s

 

***Steps 2 and 3 were done on my home desktop with a core i7-7700K @ 4.20 GHz, 32GB DDR4 ram, Nvidia GTX 1070, Windows 10 pro 64-bit, and a 512GB SSD.

Turn off color balancing to get the green color back into the mesh.

You will likely need to manually adjust the triangles in the 3D mesh custom settings instead of selecting High.  But realize the point cloud is 60 million points and the max number of triangles is 20 million so it will never be identical.

Lastly, high-end mesh settings need a computer with 128GB of RAM in my experience.

2 Likes

Thank you! Turning off color balancing fixed the issue.