Support Website Contact Support Blog

3D Mesh quality

Hi.

When I creat 3D Mesh after the Step 2 (by the comand “Generate 3D Textured Mesh”) the model is created , but with the bad visual quality. But I see that the point cloud is good.

At the Settings I selected “Hight resolution” parameter.

Why I get so bad Mesh model? What I do wrong?

Is it due that I hav not get a license yet?

Thanks!

 

Hi Binnat,

Please share with us some screenshots (of the Point Cloud and the Mesh) that highlight the problem. 
Please also share screenshots of the quality report of your project. It will help us to better understand the case :slight_smile:

Hi, Chiristina.

Thank you for response.

My point cloud is not so bad, I can say that it is good.
The problem is that Mesh model doesn’t match to the points cloud. And on the name of the 3D Mesh model was added the word “simplified”. I want to know why?

I have attached screenshot.

 

Hi Binnat,

This "simplified" is simply a naming scheme for usage inside the software: it does not mean your mesh is of lower quality.

The point cloud is quite noisy. I would recommend you to remove the noise from the point cloud (especially at the edges of the buildings), save the project and regenerate the 3D Mesh: On the Menu bar, click Process > Generate 3D Textured Mesh

Let us know how this is going!

Hi, Christina.

First there are so many noisy that, I can not cear all aof them.

Second, point coloud which I have created, not so badç if not countthe noisy. But I don’t understand that why 3D Mesh not matches to the point cloud?

Now, I have started the processing Step 2 again. Will wait the result.

I will inform you about the result.

Thank you!

Could you share the quality report of the project, so that I can have a look? I could possibly understand why we get noise in the point cloud. 

Please try to remove the noise at least at the edges of the buildings, this would help the 3D Mesh generation :slight_smile:

Yes, but I don’t know how to share the report by this page. There is not any button for attachment.

You could take screenshots of it and attach them here or upload it to Dropbox, WeTranfer, etc and share the link with us

Ok. I will send the report after finishing the processing.

Hi, Christina.

Yesterday, after several striving (trying) the software could cread 3D Mesh model and I got it.

But the result is not so good.And therefore, orthophotomosaic also not so goot, I understand that my surveying was not so good but I have got better result in Bentley ContextCapture that Pix4Dmapper. I like the Pix4Dmapper very much, but the result disappoints me a little.

I have attached the report and screenshot of the 3D Mesh by two softwares.

The Pix4Dmapper result

The BCC result

https://mega.nz/#!hE4USY7Z!C10goAvqm0b-hmh5zvC94T8BpyXDUu3s55T3isk6aVk 

Thank you very much for the technical support!

Hello,

The 3D textured mesh is generated based on the point cloud. All the points of the densified point cloud are used for the generation of the mesh. Therefore, any errors in the 3D points are reflected on the 3D mesh. Thus, the first step for assessing the quality of your outputs is to click on random points in the point cloud and check their reprojection on the images.
To do so, simply hover the mouse above the point cloud and click at a random point. Then, on the right side bar you will see how this point is reprojected on the images. If the reprojection is incorrect, you may mark more GCPs in that area or add MTPs and reoptimize the project.
Are they correctly reprojected on the images?

I assume that the two software (Pix4D Desktop and Bentley ContextCapture) are using a different point cloud for the mesh generation. I am not familiar with ContextCapture software, so I cannot assess the quality of this output.

I can though provide some recommendations for improving the results:

  1. Increase the maximum number of triangles of the 3D textured mesh. This will help to render the finer details in the model.
  1. Select  High Resolution , so that the parameters values yielding a high resolution mesh are selected.
    Process > Processing Options > 2. Point Cloud and Mesh > 3D Textured Mesh tab > Settings >  High Resolution.
  2. Select  Custom.
    Process > Processing Options > 2. Point Cloud and Mesh > 3D Textured Mesh tab > Settings >  Custom.
  3. In Decimation Criteria, select  Quantitative.
  4. In Maximum Number of Triangles, introduce a higher value. I suggest starting with a value 10 times higher, i.e. 10000000.

If it does not help, you could try improving the quality of the point cloud:

  • Adjust the parameters of the point cloud densification, to get denser point cloud
    Process > Processing Options > 2. Point Cloud and Mesh > Point Cloud tab _> Point Cloud Densification > s_et the Minimum Number of Matches to 5.
  • Draw surfaces that will be used in the generation of DSM and 3D Textured Mesh.
  • Remove the noise from the point cloud using the Point Cloud Editor before generating 3D models of your data set (3D Textured Mesh, DSM/DTM). 
    For more information about how to remove noise from the point cloud, you can take a look here: https://support.pix4d.com/hc/en-us/articles/204085149.

I hope this helps to improve the quality of the 3D textured mesh.

Regards,