Support Website Contact Support Blog

Windows Remote desktop

I would really like to see the possibility to be able to take over my workstation from home and launching Pix4D Raycloud without getting the error messages.
The suggestion to update my drivers ( which or up to date) and the message the remote desktop doesn’t work.

It does work when i go to the office start Pix4D & open raycloud, go home and take over the machine.
I would really like to see a solution which enables me to start Pix4D & specially raycloud from home without 1st going to the office start Pix4D & open raycloud.

This would be much more efficient & spare me 2 hour of commuting.

This is more of a windows remote desktop issue than a pix4d one. Remote desktop wont display 3D graphics like that. You should look into other free remote desktop software to be able to do that.

Hi, thanks for your insight.
Can you explain me why it works when raycloud is active on the workstation and I take it over from home through windows remote desktop, it shows the 3d graphics no problem.

But when I close Pix4D or start a new session everthing works untill I need to open raycloud.
Also using Agisoft, 3D graphics through windows remote desktop, No Problem.
Hexagon 3D Reshaper, 3D graphics No Problem.

Seems odd to me that you refer to Windows as the culprit when I am working with lots of other 3D graphics this way without any problems.

Don’t forget the strange thing that when I turn/leave on the machine in raycloud modus, go home and take over the machine it works with Windows remote desktop.

I find it a little bit hard to believe when you say this is a Windows remote desktop issue.

Also I believe my organisation is not to keen on using other “free remote desktop softwares” due to security reasons.

Windows doesnt enable GPU rendering over RDP, atleast by default. You can change it by doing this:

  • Open the Edit Group Policy tool from Control Panel or use the Windows Search dialog (Windows Key + R, then type in gpedit.msc)
  • Browse to: Local Computer Policy\Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Remote Session Environment
  • Then enable “Use the hardware default graphics adapter for all Remote Desktop Services sessions”
  • Update the Group policy

I dont know what viewers or codes those other softwares use but Pix4D uses OpenGL which is one of the better optimized viewers, it runs better and faster than DirectX. OpenGL is what is causing the problem because RDP does not allow OpenGL viewing. I am not sure if changing the group policy will help fix that.

I’d sugggest trying VNC or Looking Glass instead of RDP.

Thnx,

Allready had ITservices change these settings on both workstation & laptop.
As it allready explained on the Esri community.
But it didn’t solve the problem.

Don’t you find it strange it works fine when workstation is left in Raycloud and then taken over from home?
This I Can’t get my head around.

@wim.vancalster not at all when its left on your desktop you’ve initialized the driver from your local machine. You cant initialize opengl from a remote connection, which is a RDP issue, not a Pix4D issue.