Using only GCPs for reconstruction


We use both Metashape and Pix4d for creating DSM and Orthomosaics. In metashape, we rely on GCPs for the reconstruction and thus disable all cameras and update the sparse point cloud before moving onto the point cloud densification. We are attempting to process our dataset in Pix4d using settings and parameters as close to those we used in Metashape as possible. After marking our GCPs, I disabled all cameras in the Image Properties Editor, which caused the “okay” button to grey out. I thought, perhaps I needed to reoptimize the project with the marked GCPs first before disabling all cameras, but the “okay” button still greyed out. My question is whether there is a way to disable all cameras from the reconstruction, and if so, how and at what step do I need to do that? I assume I cannot add GCPs before the first processing step. Thanks.

Hi jcramer,
There are two options for setting your GCPs: one is using the rayCloud editor after step 1 completes. And the other is using the basic editor before step 1. So you will want to use the basic editor.

I don’t fully understand why you want to disable a camera. Disabling will then remove it from the processing and thus would degrade your data. What is your reasoning for doing this?

In Metashape we are able to assign all the georeferencing/optimization weight on the GCP locations, which have much smaller uncertainty than the UAS imagery which has an uncertainty of 10m or higher. We rely on the image locations for the initial alignment step, but then disable them in order to use the GCP reference during error reduction in Metashape. Disabling the cameras during the optimization steps were recommendations from internal experts. We were wondering if Pix4d operates in the same way so that we can try implementing a comparable workflow.

If this is not the case in Pix4d, does it have an internal weighting system that accounts for these accuracy disparities? The other issue we would then have is that the image reference is in a different CRS than the GCPs and we want to make sure this isn’t going to affect the accuracy of the result if we can’t do the processing without the image reference.

Hi jcramer,
I think the processing algorithms are very different between PIX4D and Agisoft. Unfortunately I am not very knowledgeable about the latter. But it appears that disabling a camera in Agisoft means something very different than disabling a camera in Mapper.

In PIX4Dmapper there is no need to disable the georeferencing of the images which is what I think you are referring to. If you process step 1 without GCPs then Mapper will use the geolocation of the images to build the initial model. Then using the rayCloud editor (available after step 1) you can then add GCPs and reoptimize. The reoptimization with the GCPs will override the geolocation of the images.

I believe the transition away from Agisoft could be challenging to many users. If you have support and upgrades available then I would suggest opening a support ticket at Otherwise I would suggest posting in the community and a member of PIX4D or the community can lend assistance.

Thanks for the help. I have gone forward without disabling the cameras per you suggestion. We have actually historically used pix4d for our multispectral imagery processing, but we also have been trying to do the multispectral processing in Metashape as it allows for more control over the whole process; however, we are running into issues with the final products from Metashape that don’t appear to be as much of an issue in the Pix4d products for whatever reason. For example, there are areas of brightness that seem to follow the flightlines, and the blue band, after calibrating using our micasense panel, is anomalously high. We think we’ve pinpointed the error to the calibration step in Metashape and that is where we turned back toward Pix4d. So at the moment we are more shifting back and forth rather than shifting away from one to another.

I appreciate the help and I will consider posting to the community to see if anyone else has run into these same issues. Thanks.

I would generally agree that there could be issues with the calibration panels. That is where I would start. However you may also want to look at the rig calibrations as well.