Support Website Contact Support Blog

Synchronization

Hi sirs,

I’ve bought a DJI Phantom 2 Vision+ 3 days ago and I try to use Capture App, unsuccessfully.

The problem is at the end of the mission. I’ve a window opened which tells me “Creation of a Pix4D project fill, Please do not switch off drone…” and nothing else. I’m waiting for several minutes, and I have sometimes to switch off the mobile hardly to close the App (I can’t close the optimization window).

Photos are on the SD Card, Mission is created in the Mission manager, but with 0/0 photos and no option to synchronize it.

In ITunes, the folder of the mission has 0kb…

I’m working with an Iphone 5, IOS 8.3, 4GB free on the phone, Phantom 2 Vision+ V3.0 with the last firmwares.

Is anyone have the same problem, or a solution?

Thanks

FX

Hi,

When a mission is completed, the application will first create the p4d file and then it will synchronize the image from the drone to the phone. The creation of the p4d file can take some time especially if there are a lot of images on the drone’s SD card. It does not only depend on the mission’s number of images but also on all images present on the drone’s SD card. A way to speed up the creation of the p4d file is to delete the images from previous missions before starting a new mission.

The speed of the p4d file’s creation will be much improved in future versions of the app.

The p4d file contains the name of the images and the accurate image geolocation. If you interrupt the process of the p4d file’s creation, it will be empty and it will not be possible to synchronize the mission afterward.

It is nevertheless possible to process the images that are on your drone’s SD card with Pix4Dmapper. However, since they contain a less accurate image geolocation, it is possible that multiple images will have the same geolocation, which can lead to some problems during the processing.

You can first try to process the images with the geolocation but if you are having issues during the processing it might be because many images have the same geolocation. If that is the case, you can remove the geolocation and process again.

If you do not have image geolocation, your model will not be scaled, oriented or placed. To geolocate your project you can add GCPs:
https://support.pix4d.com/hc/en-us/articles/202557489

Regards,

I have an iphone 6 plus with ios 8.3 with the exact same issue

I think ios 8.3 is not compatible as it disallows apps to write to the “sandbox folder”

Indeed, it seems that there is an issue with iOS 8.3 and our application when writing the p4d file. We have to make further investigations on our side and we will give you an update as soon as possible.

Thanks for your answers.

I expect the bug will not be too long to be fixed, I’m really inpatient to run a full mission with the app.

We have noticed the following issue with iOS 8.3 and the version 0.2.0 of Pix4Dmapper Capture App for iOS: After the mission is completed, the p4d file is created but the images are failing to synchronize with the device. If you are using iOS 8.2 you should not be concern with this issue. If possible we would recommend not to upgrade to iOS 8.3 to and to use iOS 8.2 with the version 0.2.0.

If you are using iOS 8.3, the p4d project file should be created at the end of the mission and is available on your device. To process the images, you have to transfer the p4d file from your phone to your computer and also the images that on the drone’s SD card to your computer. To process the images, use the p4d file, which contains the accurate image geolocation.

To transfer the p4d file manually using iTunes:
https://support.pix4d.com/hc/en-us/articles/203991949

If the p4d file takes too long to be created, you should try to format your drone’s SD card. In the next version of the application, the creation of the p4d file will be much faster since it will integrate a new version of DJI’s SDK.

We will very soon submit a new version of the application on the Apple Store which will correct the issue with the synchronization of the images and an update from DJI’s SDK. However, please note that we depend on the reviewing time of the application on the Apple Store which generally takes at least a week.

Regards,

I have been using the IOS 8.3 on iPhone 6 with the prior version of Capture and didn’t have any issues with the creation of the .p4d file, other than some images missing. They appeared to be skipped on the map view, while being captured.
Now with the 0.2.0 it isn’t writing the .p4d file anywhere. Does the capture app actually write the images on the android phone, or are the images stored on the sd card on the drone? On IOS, the images are not written, sync’d to the phone or tablet, that I have seen.

I have the exact same issue. iOS 8.3 and iPhone6+ I have the original PV2+ I have quite a few successful missions but I haven’t been able to even get the .p4d file transferred to my device. Photos are on the SD card. I’d be ok if I could just email the p4d file like I used to. The photos are on the phantom.

Hi all,

We have submitted the new version of the app for review on the Apple Store. It should take about a week before it will be available on the Store.

The bug came from a compatibility issue with the SDK on the version 0.2.0 and iOS 8.3. We have received a new SDK from DJI and integrated it on the next version of the app.

Regards,

Keeping an eye on this as I have the same issue. The odd thing is that the file (singular) that was created is a video. I will try this with my older iPhone as well, fingers crossed.

guys, why dont you try directly with andorid?

Hi all,

Unfortunately, the reviewing time on the Apple Store takes longer than expected. It seems that it will take about one more week before the application is released on the Store.

We are sorry for the delay.

Regards,

YES!!! New release online on Apple Store…

Tomorrow, I can test this version.

And now, the Free Flight Mission ? When ?

Bye

FX

I just went out and tested version 0.2.1 on my iPad and still there was no .p4d file created. The app said it was creating the file, then after 15 minutes, became totally unresponsive. Has anyone else been successful with this version?

I also tested this morning, same issue, only I let it continue, until the battery on phantom went dead. If this is working on iOS 8.3, it must be an issue with the newer hardware iPhone 6, 6+, iPad Air 2. This app on IOS needs to report errors, so that the problem can be fixed, in lieu of standing in field for hours, waiting on it to fail. The spinning gear which is akin to the os x spinning beachball of failure doesn’t provide any info that will allow for reporting or fixing the issue. It is apparent that it is not being QC’d very well. Took almost a month from last update to get non fix thru Apple. Pretty frustrating.

I’m very disappointed. Same issue than with App 0.2.0. All this time and no solution? How long will we wait for the version 0.2.2?

I guess the app is still in Beta, expecting it to work flawlessly isn’t fair. Even without the p4d file generation the photos can still be stitched with pix4d. And the Android app does work really well. It would just be nice if the iOS app also worked well.

05/10/2015 Capture app version 0.2.1 tested again with iPad Air 2, IOS 8.3. Tested extremely small area to determine if capture app would record .p4d file. Total of 18 images, no .p4d file after 20 mins. I noticed that the capture app was still trying to create file, but the expandable pop out was showing that the app was disconnected. I left app running in background, went to settings, and verified that it was not connected to phantom anymore. It was not, reconnected to phantom wifi, went back to app to verify it was connected, waited another 15 minutes, and still no . P4d file. I am interested in knowing, what version IOS device was working with this fix, since it was basically supposed to correct this issue.

Hi all,

After investigation we found out that the latest version of DJI’s SDK is still unstable and is again not always returning the list of images to create the .p4d project file at the end of the mission with the version 0.2.1. We are working very closely with DJI to solve this issue. We will keep you informed as soon as we know more about the issue and a fix.

What can help is to uninstall the app, restart the device and reinstall the app.

We are sorry for the inconvenience.

Regards,

Hi,

After uninstall and reinstall the app on my IPhone 5 with IOS 8.3, it works!!!

A small mission with a 5 images, just to try, and the p4d file is correctly created on my device, the photos downloaded before the UAV lands.

It’s a great news for me. Thanks for the help.