Select Photos by Spatial Location (and editing)

Would be really helpful if we could select input images via the map view, to then edit their features (like location, enable/disable, accuracy).

while most of the time we fly in nice patterns, sometimes we don’t or more often than not, the area we need to edit/exclude crosses several flight lines. we got close with sortable, selectable, and mass editable tables in Mapper, but lack similar tools in Matic. currently stuck editing a CSV to then re-import.

Hi @aherman

Which version of PIX4Dmatic are you using? This should be possible in the newer releases.

Here is a screenshot where I multiselected images in the 3D view and it shows me the ones it selected in the table below, where I can edit the data.

version 1.53. the 2D view is where I was hoping to select pictures. (exclude from step 1)

oh right, we still need to work to improve the 2D view, we want to make it much more interactive and enable more of the tools from the 3D view there. This is planned but will take some more time to be released.

In the meantime, the shortcut “7” should bring you to a “top view” in the 3D view, which may help to select the images in a similar manner as in the 2D view.

thank you. is there a way to view the initial picture locations in the 3D viewer prior to calibration? I can’t seem to get them to show up.

if there are geotags in the images, they’re supposed to show up even before calibration, yes.

Hm… I see them in the 2D view, but can’t find them at any zoom level in the 3D view. Does the 3D view snap to the general survey area, or is it first looking at whatever’s at 0,0,0?

That’s weird. Are you on the latest version of PIX4Dmatic 1.54.1? Available here: Download Pix4D software

In any case, some things you can try:

  1. View > View all, if they dataset is consistent it should show them (if there are outlier cameras, there may be an issue)
  2. Select a camera in the image viewer on the right, then View > Focus on selection. This should display part of the data (if 1 didn’t work and this worked, you probably have images with missing geotags).