Support Website Contact Support Blog

SDK 3.5 update for Phantom 4 Pro?

Do you have an idea of the release date for Capture App to support Phantom 4 Pro or Inspire 2?  I heard somewhere that SDK 3.5 might support them but that wasn’t not confirmed?   Will we have to wait for DJI to release new SDK?  IF so, how long does it take after that for Pix4d to update?  Or will their possible be a beta version?

Hello Gary, 

The DJI Phantom 4 Pro and Inspire 2 have just been released. It is in our pipeline to have them in our list of supported drones with Pix4Dcapture, however, we are not able to give a timeline for this integration.

The new DJI SDK 3.5 (what allows the communication between the app and the drone’s firmware), which supports Phantom 4 Pro and Inspire 2, has just been released by DJI.

In case you will have the chance to test, we will be glad to read your feedback and learn about your experience.

Best Regards,