Support Website Contact Support Blog

Samsung S Tab 2 cannot connect to CTRL+DJI

please help, i buy P4 and samsung s tab 2. my s tab 2 cannot connect to the pix4d ctrl+DJI. I already reformat the s tab 2, stiil cannot connect"

Hi,

There are more users reporting issues when using Samsung Galaxy Tab S2. 

At the moment we recommend you to try out this instruction.

Let us know if it solves the problem,

 

Hi there,

I’m having similar issues with the CTRL+ App on my Galaxy tab S2.

Seems to be a constant conflict between DJI Go and CTRL+.

When I plug the Drone controller in, the DJI Go app opens by default, but won’t connect to the Drone. Opening the CTRL+ app doesn’t connect either. The only way to use _ EITHER  _app is by leaving the controller turned on and plugged in, and re-setting the tablet.

Then I can open either DJI Go _OR _CTRL+, but once I have chosen one, the other will not work without resetting the tablet again (Even after force stopping the other app?!)

Is there a plan to address this issue with an update? It’s insanely frustrating when performing asset inspections, as I often have to use both apps in the field, and resetting the tablet repeatedly is a waste of time and battery life. The Samsung Tab S2 has a superior screen to the Apple products, otherwise I’d use the latter.

Also; I note that CTRL+ does not automatically change the focus mode of the Phantom 4 Pro back to infinite when going from DJI Go to Pix 4D, I’ve had a good number of mapping flights recently process blurry, and when watching the camera mode in Pix 4D I see the camera trying to focus every time it takes a photo? (This adds more time to jobs, as I have to perform a tablet reset another 3 times to address the issue. I think swapping between DJI and CTRL+ has worked seamlessly once since owning the drone)

Hi Matthew,

Have you been able to follow the procedure that Bla_ž_ has provided in the previous comment? Is it improving the connection or do you still experience what you are describing?

About the focusing issue you are experiencing on the P4P, a fix is going to be released soon with the new Android version of Pix4Dcapture. We apologize for any inconvenient. However, the iOS version of Pix4Dcapture can be used without having this bug.

Best,

Hi Gaël,

Thanks for the reply. I am glad to hear that the focus issue will be shortly resolved with the Android version update. I look forward to it.

Regarding the connection issues, I’ve tried a number of different fixes for the app, including Bla_ž’s_ suggested fix, however, the version of Android on my Galaxy Tab S2 does not allow me to enter the ‘Developer Options’ menu, and the other suggestion of using RNDIS is also not available as a result of not being able to enter USB configuration? (This may be a region specific problem, for the Australian release of Android perhaps?)

It seems that the only option I have at the moment is resetting the tablet… Hopefully a future release can address this problem?

Thanks again for your reply, much appreciated.

Actually, scratch that. I’ve just googled it and worked out how to enter developer mode for Android version 7.0

I’ll trial the above mentioned fixes and see how successful it is!

Hi Everyone, 

I have just tried the instructions but didnt work, I turned off the USB debug and it worked. But the main problem is I couldnt understand and describe what I exactly did to make it work. To summarize I used developer mode and turned RNDIS on but I used DJI go for defult app. after the device connected I closed and opened DJI controller and set the RNDIS again and worked!!  

 

Hope this informes.

 

Eray