Support Website Contact Support Blog

Rendering edited point cloud

I am trying to render an animation trajectory of a point cloud that I have edited, and no matter what settings I use, the point cloud is rendering with all point groups turned on in the video. I have tried to render with the edited points in a custom group, in one of the predefined groups, and also in the disabled group. All three return the same results - a video with ALL points turned on in the animation. Is this the expected result? It seems as though having a group turned off should render with that group off.

Before editing:

 

After editing:

Anyone? 

Hi Mark, 

This seems to be a bug in the software, I was able to reproduce it and have reported it to our developers. Sorry, but I do not know of a workaround so far. Thanks for reporting the issue.

Nice attempt at an offshore platform, it looks very similar to some prior work I have done as well.

Since this is a bug in Pix4D, my only suggestion is to take different pictures and change settings in Pix4D so you don’t have the noise in the first place.  Of course that isn’t easy and why I do processing for a number of other companies.

1 Like

We’re in the same proverbial boat Adam! I too am processing this for a third party client, and had to make the best of what I was given to work with. 

Hopefully Pix4D will come up with a solution to this rather quickly, as having the ability to render the classified point cloud would be nice.

Hello Pix4d Friends!!! I love this program, but today I ran into this same problem!!! I am in desperate need of this function to work properly, Please let us know when you will have this fixed! Its weird, I was able to render one good animation, just one, now each render has included in the animation all of the points that I marked as Disabled. Please help… Thanks guys!

Hello all,

Our developers are working on fixing this issue. I believe that it will be fixed in our next preview version.

Please follow our Technical Release notes’ page to get access to all the updates.: Technical-release-notes.

Great news Marili - that would be great if it can be fixed so fast. Look forward to seeing the next update.

Hello everyone, 

We have released a new Preview version 4.3.4 where we have fixed the issue described above. You can download the version from here

I’m having this same issue on 4.2.27.

The link https://cloud.pix4d.com/download/ does not have 4.3.4 available for download but instead lists 4.3.21 preview.

Does the 4.3.21 preview version have this issue fixed?

Hi John, yes please try the 4.3.21 and let us know if you get any error. 

Hello,

Unfortunately, in addition to the current release version 4.2.27, I still experience this issue with the preview version 4.3.21.

My methodology was as follows:

  1. Process step 1
  2. Process step 2 point cloud only
  3. Cleaned point cloud by assigning points to the ‘Deleted’ point group
  4. From the ‘Process’ menu, selected and ran 'Generate 3D Textured Mesh

However, the Deleted points were still included in the 3D Mesh which included (but not limited to) entire objects, such as cars, which were assigned entirely to the ‘Deleted’ point group. 

 

Edited: Confirmed on version 4.3.21, assigning points to the ‘Disabled’ point group and not the ‘Deleted’ point group resolved the issue for me. Is this an intended function of the software for both of these point groups? I ask because if the software is behaving as expected, then I recommend that the instructions of the video ‘How to edit the point cloud’ (starting at time point 4:51) found on the video academy webpage where the tech states to assign points to the ‘Deleted’ group to prevent them from being considered in further processing.

DISABLED group.

Hi John,

In the latest version, we have only the “Disabled” group. I am glad to know it worked for you :slight_smile: