Support Website Contact Support Blog

Processed XT2 Data looks wrong

Hi,

I am currently processing thermal data from the XT 2 camera. The RGB data from the camera processes with no issue. However, when I process the thermal and put my output into Arc it looks like this, rather than the temperature map that I expected.

Does anyone know what has gone wrong and how to fix it?

Hello @katherine.isabel94, Can you forward the quality report and the resultant reflectance map?

Uploading: reflectance.zip…
Uploading: 40m2_noalpha_reflectance_grayscale_1_1.tif…
@Kapil_Khanal I have attached the quality report. and the drop box link is for the reflectance map.

This issue is only happening with some data sets and not others. I am processing them all in the same way so do not understand what is happening.

I have noticed that when I am on stage 3 and I select GEOTIFF and Merge Tiles option then the thermal template is automatically de-selected. I don’t know if that is normal as the last time I used Pix4D mapper it was several years ago and don’t remember.
40m2_report.pdf (1.1 MB)

Hello @katherine.isabel94, I opened the reflectance map that you have forwarded in QGIS and I don’t see any issue with it. The reflectance map represents the temperature in the range of 15-24. See the attached image.

The resultant reflectance should be a single band with a temperature reading in each pixel. Sometimes, an issue might occur if the image is not detected correctly as a grayscale image. To verify that, you can check the Camera Model Names under the quality report and it should say Grayscale(1).


From the quality report, I can see there is some issue during the camera optimization (2). To minimize the error, use Internal Parameters Optimization: All Prior (Forces the optimal internal parameters to be close to the initial values.)**

@Kapil_Khanal Thank you for your response. It wasn’t the reflectance map I was having an issue with it was the orthomosiac created during step three. I have now figured I can change the symbology to “Stretch” in arc which converts it back to grey scale.

I do not know where to find the “Internal Parameters Optimization: All Prior” option when processing, Where is this found.

I am now also having trouble processing 3 sets of data that was taken at 20m AGL and one data set that was at 40m AGL, I did not have this issue with the 20m data I took on may 24th but I am now having the issue. When I try the first step of processing it quickly runs through it and comes up

" [Error]: Error e0046: Processing failed. No calibrated cameras." The first set of 20m and 40m that won’t process were taken with an 85% front and side overlap and the other 2 sets of 20m data were with an 80% overlap and there are a few identifiable features although most of the ground is sand and scrub. I am not having the same issue with data taken at 30, 50 or the other 2 40m data sets so I do not understand what is happening with these 4. I am heading back out to the field tonight for the final trials of this week so would like to get this issue sorted ASAP.

My camera is set up for processing as outlined below:

I have also had one data set that looks very distorted across the image, I have tried re-processing but still have the same issue. How can this be fixed?

Hello, It is never recommended to fly at 20m while using the thermal camera due to its low resolution. The calibration will probably fail at step 1. The recommend flight height is higher than 40m for a thermal camera. I would also suggest you follow the steps explained in the below support article on troubleshooting the issue related to the thermal camera.
Guidelines for troubleshooting

You can find the All Prior option under Step 1. Initial Processing. Make sure to check Advanced option (2) available at the lower left to make the Calibration option available.

@Kapil_Khanal

I flew at 20, 30, 40, 50m for my initial test flights and had no issues processing the data at that point.

I have now changed flight heights to 40, 50 60 and 70m and I am still getting the same issues and errors regardless of height. I have tried your suggestions but they have not helped. The troubleshooting page was no better at fixing these issues.

Often the first flight of the evening will process with little issues, but is occasionally skewed.

These trials are incredibly important and it is frustrating that every time I try and process the data there is some issue.

I have now raised a ticket with your support team for further support and help.

Hello @katherine.isabel94,

Can you send me any dataset with a flight height greater than 40m (ie 50m or 60m) which you are having issues with? Can you also provide the information about the image overlap? I would normally recommend having 90% front overlap and 85-90% side overlap for thermal cameras. You can insert your dataset in the link below and also add some screenshots showing what type of result you are getting. Link: HERE
Can you also provide the ticket number that you created for support?

@Kapil_Khanal The data is uploading now.

The flights were flown with 80% for both front and side overlap. I will change this for future flights to a higher overlap.

The support ticket is 107570.

Thank you for your help it is greatly appreciated.

Hello Katherine, In that case, we will take care of the issue through the support ticket and I will post it here if we find anything useful to others.