Support Website Contact Support Blog

Problems size SLPK

I’m trying to export an SLPK to publihs to ESRI online, I dont understand why if I get the export before I clean all the noise from the point cloud the SLPK has a decent size (always bellow 1/2GB) .

What I’m doing is clean the noise, clipping the area that I will be working and re-generate the mesh after that I re-export the slpk to publish on my ESRI account but I dont know why the SLPK that I’m getting are crazy big (over 5-7 GB). I tried to change processing options for a mesh (changing the Octree depth, Triangles and texture size quality) but the only thing that I’m getting is a poor quality mesh with and oversize SLPK.

Any help on that? why my SLPK from a clean mesh are getting so crazy? I should be changing any set up?

Thanks any help will be apreaciated

Hi Victor,

Rather than changing the 3D textured mesh generation settings in the processing options, you can change the settings for the exportation only (see yellow section in the picture below). This way, you will still be able to generate a high quality mesh.

You can tweak the settings for your output 3D textured mesh in the multi-LOD (level of details) format: the number of levels and the texture quality. The lower the number of levels and the texture quality, the smaller the size of your output files. For more information about exporting the 3D texture mesh, click here.

I hope this helps! Let me know how it went.

Hi Guys,

Not sure if your issue is the same as mine. I found that if I re-export SLPKs into the “lod” folder within the project hierarchy, each subsequent export doubles in size. I realised that if you delete the contents of the lod folder and re-export, the size reduces back to what you would expect.

I think Pix4D must sweep up all the lod files within the folder it resides in as part of the export.

Alternative solution would be to specify a different output folder.

Not sure if this is a bug or if it can even be replicated. Worth checking though!

Hi Geo West,

 

I have done the following test, and I was not able to reproduce the behavior you have described. 

Could you please let me know if I am missing something in my testing?

  1. I have opted for SPLK generation 

  1. OK

  2. Open the results folder 

  3. Checked the size of the textured mesh saved as a .splk file 

  4. Create a duplicated of the lod folder to further serve for comparison (see lod_copy in the screenshot)

6.  Generated LOD Mesh and export it again with the same options

  1. Compared to the first results in the matter of size

Following this test, the size of the files in my case was the same.

 

Cheers,

Ina

 

Hi Ina,

Thanks for the response. Looks like you have exported under slightly different conditions to me. The doubling issue i found when exporting an SLPK into the same lod folder:

  1. Settings used for each export.

 

  1. SLPKs created when making a new export into the LOD folder, just changing the SLPK name incrementally.

 

Solution is to do as you have and manually create a new LOD folder for each export. However, as this isn’t automated in the export UI of Pix4D, it might be useful to stipulate this, or is it a bug? Cheers

 

FYI, i manually renamed TRAIN, to TRAIN1 and TRAIN2 before exporting each time in the UI. Pix4d didn’t do this automatically.

Hi,

Thank you for taking time to report this issue. After following the steps, you have provided I have reproduced the same behaviour as in your case. Indeed this should not be the case. At the moment we believe that it may be linked to the zipping. To further be investigated I have reported the issue to our developers so they could look into it. 

As soon as I will ahve updates, I will post it here.

Thank you,

Ina