Support Website Contact Support Blog

Phantom 4 and Pix4d

What is the status of compatibility with the Phantom 4 and Pix4D capture software?  Is there a general plan in the works?  

Hi Adam,

DJI will very soon put the new Phantom 4 on the market (15th of March) but it is possible to order it now.
It is not compatible with Pix4Dcapture yet, because the specific tools to develop applications that command the hardware are not available at the moment.

However, making the Phantom 4 compatible with Pix4Dcapture on both Android and iOS devices is in our pipeline. Our Capture team will work on the integration of this new DJI drone as soon possible.

Regards,

Hi, Do you guys

Do you guys have an ET on the release for Android Pix4Dcapture version for the Phantom 4?

 

Best Diego

Hi.

I wonder when you are going to release support for Phantom 4? What is your best guess?

Arne 

Still wondering about this? Android support?

Hello,

The Android version is still in development for the Phantom 4. Unfortunately, there is no release date set for the moment. We will post an update in the official forum post, as soon as there is a new version. 

Best regards

Really waiting for the Android version with Phantom 4 support…

Hello,

I have tried twice to solve the bundle block, using GCPs with accuracy 1-2cm, but the the RMS is a lot bigger. In my first project with GSD 0.5cm I had an RMS 7cm, with some GCPS with a much bigger error especially in Z. In the 2nd project with a GSD 3 cm I had an RMS 14cm, the camera optimization wasn’t bad it was 3 and 5% the relative difference between initial and optimized internal camera parameters. Isn’t it supported yet ? With the phantom 3 pro I didn’t have this kind of problems.

Thank you !

Hi all,

We are aware of our users’ needs regarding the Phantom 4 support on Android. Our developers are working on it and are fixing the last details to make it stable. They are doing their best considering the different tasks in their pipeline.

Every news and updates will be announced in our official forum post:
https://support.pix4d.com/hc/en-us/articles/hc/communities/public/questions/203121499

You can follow this post to be notified when the content is edited. Click the “Follow” button on the top right corner of the post to follow it. Note that you need to be logged in with a Pix4D account to click this button.

@ Ilias:

Which drone did you use for the two projects?
Could you please share with us the two quality reports corresponding to the projects with the accuracy issue:
https://www.dropbox.com/request/dSAE5BVE5bAp5tzks9cI

Regards,

In both projects I used the phantom 4, I just uploaded the reports. The weird is that I didn’t have this kind of issues with the previous phantom 3 pro. 

Thank you for your time and interest!

Hi Ilias,

Thank you for sending the quality reports. The GCP adjustment could indeed be improved.

A first explanation is perhaps the camera model. In the quality report, we see that the camera model is read from the image EXIF meaning that a corresponding camera model was not found in the database. In our latest version of Pix4Dmapper 2.1.53 for Phantom 4, there are two optimized models:

  • FC330_3.6_4000x3000 (full resolution)
  • FC330_3.6_2000x1500 (half resolution)

Since the resolution of the images is 4000x2250, one or the other model cannot be used. This is why in this case you will have to manually optimize the camera parameters following: https://support.pix4d.com/hc/en-us/articles/206065716

A second factor that could explain the large RMS error with respect to the GSD is the vertical error. Sometimes depending on the location of the area, the vertical geotags are not very accurate. This is problem of the DJI firmware. This error can reach a shift of 100 meters. Then the vertical error is large but without taking the vertical error, the global RMS errors become more reasonable.

Lastly, given the very small GSD of 0.5 cm it is important to mark the GCPs having a sufficient zoom level so that the software can take most advantage of the high precision. When marking the GCPs, make sure to zoom in.
In addition we noticed that targets on the ground are not ideal for the software like for GCPs 2000, 2001, 2005, 2019… Indeed the shape is circular which increases the error when adjusting the model to the GCPs compared to a target with two black squares.

Hope this clarifies the situation.

Regards,

Have you had any complains about phantom 4 and pix4d capture, I tried to use it with my android phone Note 3 but couldn’t. It showed me some strange errors that didn’t exist. I didn’t manage to fly it. I noticed also that in ios there are more opions like double grid, are you going to upgrade the android version too ; 

Thank you !

Hi Ilias,

Did you make sure:

  • To have installed the latest P4 firmware?
  • To have the latest OS version on the device?

If you have any doubts on the optimal workflow to follow with the app, you can refer to our getting started:
https://support.pix4d.com/hc/en-us/articles/202557269

Could you maybe provide more information on the error you got? Where did it happen?
Did you take a screenshot by any chance?

Regards,

I used the Phantom 4 with spectacular results. Using a Samsung S3, it displayed the live video perfectly, compared to the djiGO app which tears the screen and blocky video is difficult to use. I suspect this is because of acceleration/overlay use in the pix4d. 

Also the default settings are highest overlap, and 30 meters, which is too conservative for success. I had to lower the overlap and the height (maintain situational awareness!) to get results. 

Transfer for 20 pictures took 10 minutes. Default settings took 90 pictures (of course depending on area, this was approx two football fields in size) 90 pictures never transferred - app quit and restart. While I appreciate the restart resiliency of not starting from the beginning, the stability isn’t very good on the image transfer. Perhaps it was simply the diminutive Samsung S3. Also, once I installed Pix4d, the djiGO app failed to work. removing and reinstalling djigo didn’t work… I simply resolved to dedicating a controller device to specific tasks, i.e. the S3 is only used for pix4d testing now :wink:

I HIGHLY recommend skipping wireless the transfer mechanism with the Phantom and just transfer sdCard to a desktop Pix4DMapper.

Hi David,

Thank you for sharing your experience and your nice feedback!

Pix4Dcapture and DJI GO can both be installed but they should not be running at the same time. To disable one or the other, you can have a look at this article: https://support.pix4d.com/hc/en-us/articles/209626486 

Also make sure that no app is selected by default: https://support.pix4d.com/hc/en-us/articles/212300043

It is true that the image transfer is not working smoothly. Our developers are working to improve it. In the meantime as you said, processing from scratch and importing the images saved on the drone’s SD card is good option:
https://support.pix4d.com/hc/en-us/articles/204911905

Regards,

 

Hi David

 

Did you change any of the Phantom 4 camera values or did you get the good results with default settings?

I am getting relative difference > 25%. Camera model correctly reports as “FC330_3.6_4000x3000 (RGB)”. Overlap was set at 80% and height was 50m.

What am I missing?

Hi again I just found some time to reply, I still have problems with the android app, when the Phantom reaches the start point it stops in the air, it doesn’t begin to the first way-point, it shows me an error about time out, and waits there. I have updated both my phone and the pix4d capture and  I tried to use another phone to, a Samsung Galaxy 5 but still the same.  I had to use other apps for flight planning like DroneDeploy or Datamapper and worked fine, I can’t find what goes wrong, with phantom 3 It worked better, it had some issues but not like that. Who knows it might be time to change phone :-).

Do you intend to update the app and add features like’s apple version ?

Hi Dirk I had some issues in the beginning when I first bought it, with the internal parameters, it didn’t recognize the camera and didn’t have the right internal parameters, so I had to change it manually but now works fine and I have good results with a relative difference between initial and optimized internal parameters of 0.5 %, with GSD of 3.1 cm I got an RMS error 2.9cm in my last project. Big difference I also had when I used the algorithm of rolling shutter, because usually the drone is moving when I shoot the photos.

Regards

 

@ Ilias Pontikas

Getting same issue with first waypoint. Using Samsung TAB A.

0.5% difference on camera is great, what internal parameter settings did you use?

I used this camera from the database :

FC330_3.6_4000x3000 (RGB). Sensor Dimensions: 6.317 [mm] x 4.738 [mm]

They are saved locally in every p/c, I could send them if you like.

Hi Ilias

 

Many thanks for your kind assistance.

I had the same camera selected as Pix4D identified it from the exif data.

Now opted for linear rolling shutter option and re-ran the project (363 x 12Mp photos). Will know in a few hours.

Was that all you changed?