Support Website Contact Support Blog

phantom 3 capture app

I have Phantom 3 Professional FirmwareBeta V01.04.0001, and on the page of sdk there is a new FirmwareBeta V01.04.0005 , so, do i get that firmware or i let the FirmwareBeta V01.04.0001

Hi Issrael,
Unfortunately both firmware are not yet supported by the current version of our application (v 2.0.2). More information on this post:
https://support.pix4d.com/hc/en-us/articles/hc/communities/public/questions/204542545–Android-Beta-Phantom-3-Professional-Advanced-and-Inspire-1?page=5

We are currently developing the next release of the beta (v 2.0.3) with the beta firmware V01.04.0005.

So you can already install it and when the update will be available it will be compatible with your drone.
Regards,