Support Website Contact Support Blog

Map is inverted after converting to local coordinate system.

As the title states I shot some GCPs in a local coordinate system and followed the Pix4D instructions on how to convert the project to that local coordinate system. After it was done crunching it sort of inverted the project so the the easting and the elevation are backwards. I tried following the Pix4D instructions on orientation constraints and that didn’t solve this problem either. What am I missing?

Edit: I just realized I may have left out some vital information. I will attach some more quality reports to show my progress here. The one thing that I didn’t mention that I thought was relevant was that I after adding the GCPs I re-optimized before calibrating. Now that I’ve typed this all out and added the extra quality reports I realized that re-optimizing after adding GCPs is a necessary step before you can calibrate the site. I hope I didn’t confuse this issue any more but I’m going to push forward with this edit.

https://we.tl/t-HL8kdSIVWQ

Midland_LC_report.pdf: Initial processing with geolocated photos.

Midland_LC_report2.pdf: Is after adding GCPs that were recorded in a local coordinate system and before I realized I need to “calibrate” before reoptimizing.

 Midland_LC_report3.pdf: Calibrated and then reoptimized here and tried adding Orientation Constraints.

Midland_LC_report after removal … .pdf: Here I removed mtp1 because of the wild elevation error.

Midland_LC_report-mtp fix … .pdf: I tried using manual tie points to fix the light area of 2D Keypoint Matches near the top.

This is a screen shot of the last re-optimization:

 

 

Hi Daniel,

Thank you for the detailed description of the workflow and the attached quality report. 

From what I see your workflow is correct and the most probable cause of the issue is the order of the imported coordinates.

Could you try changing the order of the GCPs (e.g. XYZ -> YXZ) and importing the GCPs again? Does the orientation change?

More information in the How to add / import GCPs in the GCP/MTP Manager article:

Best,

 

It didn’t change. I changed the format to YXZ but I also told Pix4D that I was uploading in YXZ format. Should I have kept Pix4D in XYZ format and uploaded my points in YXZ to sort of trick it? 

The curious thing is northing is correct (as far as the direction it’s pointing), it’s the easting and elevation that are backwards.

Any thoughts?

Got it. I was over thinking it! Just load the points in YXZ format instead of XYZ. 

 

Happy to hear the issue is solved! :slight_smile: