Support Website Contact Support Blog


Im trying to use the pix4dcatch on my iphone 10.
I have signed up, but when I go to login on the app, the screen is cut off and there is no submit button.
So Im stuck being unable to log in to my account.

Hello Josh,

The issue is known to us, it happens when you login using the browse on a phone in landscape. So, for now, can you tap on the below icon and than login to see if that helps to solve your issue.


That works thank you!

when i posted this comment I got an email that said my account would be frozen? I assume that is not correct?

You should be able to use your account. There shouldn’t be any issue.


Dear Pix4D,
I’m unable to log-in since the account pop-up remains empty (version 1.0.1; iPad Pro 2020; iOS 13.5.1). I have tried to re-install the app and rebooted the device: no luck with that. Is there a way to get the app working? I would really like to get working with the app and take advantage of the LiDAR capabilities.

thank you!


It is weird because you should be able to see something. It might happen due to unstable internet connection. Can you try to login using the cellular data or better internet connection.


Unfortunately, that’s not the problem; the pop-up remains empty. I have tried multiple WiFi-connections and cellular. Deleting the app and re-installing didn’t help either. Is there some kind system-file that could be damaged as the cause of the problem?