Support Website Contact Support Blog

Kml aparece desplazado 50 metros sobre Google Earth

Hola!

He generado muchos ortomosaicos con Pix4D, pero alguna vez sucede que, al abrirlo en Google Earth, aparece desplazado varios metros (puede ser en cualquier dirección) sobre el mapa original sobre el que se ha realizado el vuelo. La imagen es buena, bien sea RGB, térmica o multiespectral, pero no coincide con el terreno.

¿A qué es debido esto? ¿Se puede solucionar una vez adquiridas las imágenes?

Gracias

Hola Isabel,

Por el momento, no puedo decirles lo que está pasando.
¿Se ha asegurado de que ha seleccionado el sistema de coordenadas correcto?
¿Están todos sus proyectos en el mismo sistema de coordenadas?

¿Podría subir aquí el informe de calidad del proyecto en el que tiene este número?
OneDrive

De lo contrario, como solución temporal puedo recomendarle que georeferencie su archivo *.kml con QGIS. Pero admito que no es la solución óptima.

Saludos

Hola, Marco:

Subí dos informes de calidad para analizar este problema, aunque no he recibido ninguna contestación.

Por otro lado, al procesar varios proyectos realizados con cámara multiespectral Sequoia, aparece este mensaje en la pantalla cuando se cargan las fotos. No me es posible llegar a cargarlas porque indica que no tienen georreferenciación. El vuelo se realizó sobre un DJI Matrice 210.

Tampoco antes me había encontrado con este mensaje. ¿Tienes idea de a qué se debe y cómo se soluciona?

Gracias

Buenos días,

Trataré de contestar a sus preguntas:

- Desplazamientos en Google Earth:

He analizado los dos informes que has subido.

En el caso del proyecto térmico lo que ocurre es que los valores optmizados de la cámara son totalmente distinitos a los iniciales:

La focal pasa de los 13 mm originales a 38.6 mm, es decir mas del doble.

Esto tiene repercusión en la escala del proyecto que junto al hecho de no tener GCPs hace que el resultado sea erróneo.

Cuando ocurre esto, la recomendación es utilizar “All prior” que fuerza al software a no cambiar demasiado  los valores iniciales durante el ajuste.

Mi recomendación sería repetir el proceso utilizando ese parámetro.

En el caso del proyecto RGB, lo que está ocurriendo es que las conexiones entre imágenes no son nada buenas y además hay imágenes que no quedan calibradas:

 

Probablemente esto ocurra porque estás usando el método “alternative” como calibration method. Dicho método está optimizado para terrenos llanos (puede fallar en zonas ondualdas)  y no estoy seguro que este lo sea.

Mi recomendación sería procesar de nuevo con “standard” en vez de alternative. Por otra parte al ser un terreno con vegetación, recomendaría utilizar una escala de imagen de “1/2” en vez de “1” que es lo que estás utilizando.

- Proyecto Sequoia

Cuando se utiliza la cámara Sequoia, el software detecta automáticamente esa cámara (está en la base de datos) y la define como rig. Lo que aparece es algo parecido a esto:

Creo que lo que está ocurriendo en tu caso es que por algún motivo, no se estña detectando como rig y por eso el mensaje de que las posiciones son las mismas.

Para ver lo que está pasando necesítariamos 3 imágenes completas, es decir, 3 grupos de imágenes con todos los canales.Te pediría que las subieras al mismo onedrive y nos avises cuando esté listo.

Un saludo.

 

Buenos días:

Subí las imágenes que me pedisteis para analizar el comportamiento del procesado con imágenes multiespectrales. No sé si llegó el aviso.

Espero vuestra respuesta. Muchas gracias

Un saludo,
Isabel

Buenos días de nuevo,

El siguiente artículo explica como procesar imágenes de Sequioa: How to process Sequoia imagery

Es necesario procesar las imágenes RGB separadamente. Quizás sea eso lo que esté causando el problema. El rig está definido con 4 cámaras correspondientes al canal verde, infrarrojo, rojo y red edge. 

Un saludo.