Support Website Contact Support Blog

orthomosaic not lining up with Google Earth

My ortho is not lining up with google earth.  I used GCP’s in Michigan State Plane, International feet, NAD83, South zone.  When I insert the KML into google earth my ortho image is shifted about 27ft to the East.

Please help.

Thank you,


Hi Scott,

Could you please send us some screenshots of the quality report (or the quality report itself)? I would like to see the errors you get on your GCPs. If you get very small errors, then your model is well tight on your GCPs and the issue may come from the accuracy of Google Earth. Google Earth may have different levels of accuracy at different places on the earth :slight_smile:



Here are some screen shots of the project.  I could not figure out how to email you so I did screen shots.  I think the problem is that Michigan coordinate system uses international feet and not us survey foot.


Hello Scott,

When exporting the orthomosaic into kml, the software has to convert from the output coordinate system into WGS84. Maybe there is a problem in that conversion.

In order to troubleshoot, I found this website which allows you to convert from any coordinate system into Google Earth: 

You can type in X,Y coordinates in any system and fly to On Google Earth.

Would you please type one of the GCP coordinates in this website and fly to the exact point into Google Earth?

You can select your coordinate systems and units, either meters, feet or US survey feet.

Please check if there is a displacement too and let me know.

If there is no displacement, there is a problem in the Pix4D conversion and we should investigate it further.

Thank you very much.



The coordinates lined up using the website. Below are the coordinates. Looks like there might be an issue. I think it has something to with the way pix4d processes international feet and US Survey feet.

Center of Sanitary Manhole
Easting: 12786095.43
Northing: 286806.79
Elev: 845

Thanks for your help.

Here are some snap shots of the point

THis is the CAD file with pix4d orthomosaic image.  The manhole in the center of the picture is the GCP.

This is google earth with the coordinates of the GCP.  Everything looks good here.

Google Earth with the KML file from Pix4d.  The GCP is now in the center of the drive and not over by the curb.

Hello Scott,

Would it be possible to upload the project to the cloud?

In case so, Please follow these instructions (it is not necessary to process, just upload)

Thank you very much.

I have uploaded my project to the cloud. It’s called WMU Elmwood.

Thank you

Hello Scott,

I downloaded your project and I did the process. I got the same shift that you are experiencing.

The coordinate system that you are selecting is “NAD_1983_StatePlane_Michigan_South_FIPS_2113_Feet”.

As other software packages, the definition we use is coming from .

The system is defined as follows:

PROJCS[“NAD_1983_StatePlane_Michigan_South_FIPS_2113_Feet”, GEOGCS[“GCS_North_American_1983”, DATUM[“North_American_Datum_1983”, SPHEROID[“GRS_1980”,6378137,298.257222101]], PRIMEM[“Greenwich”,0], UNIT[“Degree”,0.017453292519943295]], PROJECTION[“Lambert_Conformal_Conic_2SP”], PARAMETER[“False_Easting”,13123333.33333333], PARAMETER[“False_Northing”,0], PARAMETER[“Central_Meridian”,-84.36666666666666], PARAMETER[“Standard_Parallel_1”,42.1], PARAMETER[“Standard_Parallel_2”,43.66666666666666], PARAMETER[“Latitude_Of_Origin”,41.5], UNIT[“Foot_US”,0.30480060960121924], AUTHORITY[“EPSG”,“102690”]]

As you see, the units are “Foot_US” which means that even although the coordinate system is called “…_Feet”, the definition uses Foot_US, and then the software is treating the units as US_foot and not international feet.

That is the reason for the shift.

That is to say that the official definition is in US foot so you should import the coordinates in US_foot and not international feet.

There are other systems which end in “ftUS” (also in Pix4D)  but unfortunately, it is not the case for this system and that causes the confusion.

I hope this helps you.




Michigan Coordinate systems are expressed in international feet and not in US Survey foot. 


Sec. 3. The coordinates for a point on or near the earth’s surface that are used to express the geographic position of that point in the appropriate zone of this system shall consist of 2 distances. Each distance shall be expressed in United States survey feet (1 foot = 12/39.37 meters) and decimals of a survey foot if using the Michigan coordinate system of 1927, or shall be expressed in meters and decimals of a meter or in international feet (1 foot = 0.3048 meter) and decimals of an international foot if using the Michigan coordinate system of 1983. One of these distances, to be known as the “x-coordinate”, shall give the position in an east and west direction; the other distance, to be known as the “y-coordinate”, shall give the position in a north and south direction. The coordinates shall depend upon and conform to values published by the NOAA/NGS for the monumented points of the North American horizontal geodetic control network, the coordinates of which monumented points were computed on the systems designated in this act. History: 1964, Act 9, Eff. Aug. 28, 1964;Am. 1988, Act 154, Imd. Eff. June 14, 1988

Is there any way to use international feet and have the kml file work?  Could Pix4d fix this issue so orthomosaics line up in google earth.  There are many surveyors in Michigan that use International feet for their coordinates.

Hello Scott,

Sorry for the late reply.

Pix4D allows importing any coordinate system via prj file.

You can download the prj from this link:

it contains the definition of your system in international feet.

If you download the prj file and import it into Pix4D, there is no shift. I just did it.

In order to import it, please follow this article.