Support Website Contact Support Blog

ITRF 2014 7789

ITRF 2014 7789 is missing from pix4d, I have tried writing a prj file and uploading it to pix4d but it gives an error. Can I get feedback on how I can add the coordinate system to pix4d, I need it for my project. Below is what I wrote in my prj file.
GEOCCS[“ITRF2014”,
DATUM[“International_Terrestrial_Reference_Frame_2014”,
SPHEROID[“GRS 1980”,6378137,298.257222101,
AUTHORITY[“EPSG”,“7019”]],
AUTHORITY[“EPSG”,“1165”]],
PRIMEM[“Greenwich”,0,
AUTHORITY[“EPSG”,“8901”]],
UNIT[“metre”,1,
AUTHORITY[“EPSG”,“9001”]],
AXIS[“Geocentric X”,OTHER],
AXIS[“Geocentric Y”,OTHER],
AXIS[“Geocentric Z”,NORTH],
AUTHORITY[“EPSG”,“7789”]]

Hi Kishan,

were you able to define that coordinate system (EPSG:7789) in other software? Is it correctly recognized?

It seems like Pix4Dmapper does not recognize GEOCentric Coordinate Systems.

Are you defining this CS for the images or for the GCPs? Could you try to define the CS as arbitrary? In that case are the images/GCPs placed in the correct position?

Hi,
The coordinate system is available on Qgis

Pix4Dmapper does not accept GEOCCS. I have tried to import also other GEOCCSs with no success.
Keep in mind that this Coordinate System cannot be defined as output CS as it’s not a projected one.
Did the arbitrary option serve your needs as a workaround?