Support Website Contact Support Blog

Incorporating DJI photos with incorrect EXIF GPS data

To help preserve battery, I took a few photos with my DJI Mavic 2 Pro not in flight. This method didn’t seem to work very well, because the drone frequently became uncalibrated. The EXIF data from some photos therefore erroneously reads as follows:

image

Here is the resulting map view in Pix4D:

The processing is finished but I cannot see anything in the rayCloud:

You can see that I tried adding a Processing Area .kml from Google Earth. I figured that the rayCloud camera was very zoomed out, and that was the reason I couldn’t see anything. I tried selecting the Processing Area and zooming into the selection, but this did not work.

Any suggestions? Should I just not incorporate the photos with the bad EXIF data?

Hi,

Thank you for your message. I will reply in the direct ticket. Once a solution is found, I will post it here.

Cheers

Hi Daniele,

The solution is to sort the photos in the Image Properties Editor by latitude or longitude and disable them, as I did here:

I am now dealing with a new issue that is detailed in this thread: how to visualize blocks to aid placement of manual tie points?

I have 4 blocks of data after processing. I’ve been adding manual tie points, hoping to connect the photos of each block. The issue is it seems the only way to add a MTP is by first clicking a point in the rayCloud, and this does not give you all the images to work with, only the few where the ATP that you clicked is visible.

Hi,

We are glad to hear that disabling the acquisition with no geolocation was helpful to get satisfactory results.

Regarding your second question, I suggest you post directly in the mentioned thread or contact us directly at Pix4D Personal Support. Don’t forget to send the full quality report.

Cheers