Import Error p4d files

I am trying to import .p4d files into PIX4Dmapper and no matter what I try I keep getting the same message “The project could not be imported because the corresponding results folder (/Users/xxxxxx/Project 00001) is missing or unreadable.
Place the “Project 00001.p4d” file beside the results folder and try again.”

Does anyone have any solutions?


May I ask by import do you mean opening a .p4d file?

If it does not work by opening a project in the PIX4Dmapper, you may also go to the folder where you have the file and click on the .p4d folder to open the project.

If this does not help, would you mind providing some screenshots of the error message? Thank you in advance!


Yes I meant project, not file.

I have tried opening the project in multiple ways, there is no issue either when I open the project in textedit.
Please see the attached screenshot of the error.

Hi Shauna,

Thank you for sharing the screenshot.

It is more clear to me now that the software you are trying to import or open a .p4d file is PIX4Dsurvey.

Have you tried opening the .4d file instead of importing it?
You can go to Menu > File > Open.

Also, this article could be useful: How to import a PIX4Dmapper project into PIX4Dsurvey

Rosana (she/her)

I have tried opening the file, importing it, dragging it onto the home screen, and I get the same error every time. I have restarted, redownloaded too.
I haven’t had this issue previously on other operating systems using other accounts.

Hi @sharky,

Please could you send us a screenshot of the PIX4Dmapper project folder structure?
I am referring to what is described in the following article: Project Folder Structure

Please, if you can, set your Finder Windows as column view, that would be great. See the follow screenshot for reference:

I am looking forward to your answer.

Have a very nice day!

Best regards