Support Website Contact Support Blog

I can't edit densified point cloud

I have three computers at my UAS drone class that are dedicated to processing 3D models with Pix4dMapper (trial version). All 3 computers have the same specifications, hardware, RAM, software, etc. One of the computers allows me to edit my densified point cloud. The other two won’t. The computer that does allow edits has the colored point cloud while the other 2 have just a black point cloud. That infers some type of correlation, perhaps? Regardless, I can not clean up my models if I am unable to edit the point cloud.

To clarify: I select the “Edit Densified Point Cloud” widget. It asks if I want to load the point cloud. I select OK and it loads the black point cloud. After it instructs me how to use the point cloud editor, I draw a polygon around the area I want to assign to the “Deleted” point group. I click Assign and nothing happens. The cloud points neither turn red nor do they seem affected by the point cloud editor.

Help.

Hi Adam,

Since you are able to successfully use the point cloud on the first computer we suspect a display issue.

Do you perhaps have two graphic cards installed on the computers showing a black point cloud? We recommend to make sure the correct GPU is selected to use Pix4D Desktop in the 3D settings of the computer. Could you also confirm you have the latest driver installed?

Cheers,

Similar issue here.  I’ve processed 2 different data sets on 2 different machines.  Machine A can load the densified point cloud that it generated, but can’t load the one Machine B generated.  Similarly, Machine B can load its own point cloud, but not the one generated on Machine A.  Both can load the Textured mesh each other generated, just not the other’s point cloud.  The log file simply says this about trying to load the point clouds:

“Time spent loading the layer: 000ms, total number of points = 0”

I don’t even get a black point cloud – I get nothing.  It’s like it immediately aborts the import for some reason.

And no, I don’t have 2 video cards, just one single GTX960 on Machine A and a Quadro FX 3800 on Machine B.  Oh, and both machines are running v3.1.22.

@Robert: could you try with version 3.2.23 to see if the same problem happens? It’s available here: https://cloud.pix4d.com/download/ 

Same result with 3.2.23.  The green progress bar along the bottom flashes for a split second then disappears, and the status bar says “Filters applied”.  The smaller green progress bar that appears below the point cloud name in the Layers tree remains, but is white, ie shows no progress.  It did this on v3.1.22 too, by the way, I just didn’t think it was relevant.  But it at least illustrates that it starts the loading function, then aborts for some reason.

Thanks in advance for any further help you can provide, Pierangelo!

Maybe it is related to how you transfer a project from one computer to the other.
Do you have the project stored on a server that is accessible by both? Or do you transfer the project from one computer to the next? More information on how you proceed will help to understand the issue. 

Please make sure that you transfer the images, the .p4d file and the entire results folder of the project (should have the same name as the .p4d file) to the other computer. If all three are not available on the computer the project cannot be opened. Let us know if that solved the issue. 

The project folders are stored locally on each machine (ie, on the HDD), but I use a file sync program (“Beyond Compare”, it’s awesome) to copy/update files from one machine to the other.  The project’s resulting folder and file structure on Machine A is an exact duplicate of that on Machine B.  The folder of input photos is also stored locally on each machine.

Very similar to krusader in linux.

Nice!

I would need more information to understand what could cause the error. Maybe I can find something in these log files: 

  • Project A on machine A (that worked)
  • Project A on machine B (that does not work)
  • Project B on machine B (that worked)
  • Project B on machine A (that does not work)

Could you upload these log files to a file sharing service (e.g. Google Drive) and post the link here?

Hi

Since last week, I have the same problem: the point cloud editing is disable for new projects. Even if the point cloud is created and loaded.

I’m using Pix4D 4.2.27 version. I did not happen before with Pix4D previous versions. I loaded a project created with an older version and the point cloud editing is enable (using 4.2.27).

Why point cloud editing feature is disable for new projects? There is a known solution? is it about confidentiality and shared data issue? (recently I was prompted to modify it). Point-cloud-editing issue come again with this new version?

In the next weeks we will be working on new projects. Point cloud editing will be particularly crucial for these projects.

System: Pix4D 4.2.27 version. Win 10 build 17143. Ryzen 1800x 32 Gb RAM GTX 1080.

Insight :slight_smile:

Hi Daniel,

There is indeed a bug in this latest version. Our dedicated development team is working on it, but for the moment the only way to enable the feature is to close our software and re-open it.

The bug will be fixed in the next Preview version (to be released in a few weeks).

We apologize for the inconvenience.

I’ve just updated the software to ver 4.3.33 and I’m having the same problem. I load the point cloud hit the edit tab point cloud dissapears.

Any help would be appreciated.

Thanks

Hi Glenn,

Is this an issue that only happens with one of the projects or the “Point Cloud Editor” is not available for all the projects?

Do you have the chance to try it on another computer? Do you face the same issue?

Best,

Hi Blaz,

This is happening on all projects. Just wonder if I’m doing something wrong in my processing. this has been happening for about the last month. Maybe I can activate the pix4d on my old machine and give it aa try.

Thanks for all your help.

Glenn Martin

Blaz,

I tried a 400 image data set on my old Dell and low and behold I could edit the point cloud. Dont know where to go from here.

My big machine utilizes an Intel I7-7820x cpu with 128 gb ram has a Radeon Pro WX 7100 GPU, 8GB Dual SSD.

Any Ideas?

Glenn Martin

Thank you for checking it on another computer. This can give us a hint that we should check if the configuration of the workstation is causing the issue. 

Could you provide the following:

  • Could you confirm that the issue started directly after updating to the 4.3.33 version? Which version were you using before?
  • Are you using multiple graphics cards? If yes, which ones? Are the drivers updated?
  • Could you share:
    ▸ The specifications of the workstation (System Information .nfo file)
    ▸ The project log file (text file): …\project_name\project_name.log
    ▸ The project file (.p4d): …\project_name.p4d
    ▸ One or several screenshots of the 3D rayCloud view showing the issue you face.

The files can be uploaded here.

Blaz,

I encountered the problem while I was using Ver. 3.27. something. Everything had been working well then all of a sudden I couldnt edit the point cloud. After procesing I would save the project then restart Pix4d to try to edit the point cloud. Couldnt edit the point cloud. This  is when I decided to upgrade to ver. 4.3.33. This did not work so I upgraded to the latest ver. 4.10.08?

I will be sending you the information you asked for earlier. Just havnt had time recently. 

Could you confirm that you are not able to use the Point Cloud Editor as shown on the screenshot ( rayCloud - Point Cloud Editing)?

As a side note, it is expected that the Point Cloud Editor is not available in the Map View and Volumes module.

Yes Blaz,

I cannot edit the point cloud at all. When I switch to edit point mode all the automattic tie points dissapear.

Can you hook up to my computer and check it out?

Blaz, would it be possible for you to take control of my machine and trouble shoot it?