Support Website Contact Support Blog

GoPro Hero4 Session camera settings don't seem to work--no images calibrated successfully

Hi, all–

This is my first time trying Pix4D Discovery out to see if it will fit my needs.

I have a GoPro HERO4 Session set as advised to take 8MP stills at 0.5sec intervals while I am walking around my neighborhood. I am currently turning the camera 80 degrees off to the right from my centerline while walking, and the photos appear to have plenty of overlap.

When I run the initial processing, the Quality Report pops up with a red warning exclamation point: only 9 photos calibrated out of 994.

I look at the camera settings, and for some reason the entry that is auto-detected for the HERO4 Session thinks the camera has a perspective lens instead of fisheye. So I changed this to fisheye, left the other settings alone, and re-ran the initial processing. (Load optimized settings was greyed out for some reason.)

This time it came back with 0 photos calibrated out of 994 and didn’t even finish the initial processing (no Quality Report produced). I got a paragraph of text on a pink warning background with links to helpful tips.

I know for sure the HERO4 Session is a fisheye camera. I don’t have the exact settings to punch into the camera’s editor such as sensor width, etc.

How do I get past this point? Anybody know what Pix4D expects to be input into the camera editor for the GoPro HERO4 Session?

What I will do later is a test run using an iPhone 5S in stock configuration (no fisheye lens) and see if that works.

Thanks in advance!

Hi Dennis,

Sorry to hear that you are having issues calibrating your GoPro Session images. Please consider sharing your project with our support team to help us better assist you. Normally a Quality Report would be enough to determine what is causing the issue, but given the low number of calibrated images it may be necessary to inspect the quality of the original images.

You can upload your project files and images to Pix4D Cloud and send an email to support@pix4d.com.

Not sure how to upload your project files and images to Pix4D Cloud? https://support.pix4d.com/hc/en-us/articles/202557689#label3

Consider also reading our recommended image capture parameters at https://support.pix4d.com/hc/en-us/articles/202557459.

Oblique projects present a couple other factors that need to be addressed, namely the amount of usable image content available for Pix4Dmapper to refine your camera calibration. You can learn more about things to consider when capturing oblique imagery by watching the first fifteen minutes of Webinar 10: https://support.pix4d.com/hc/en-us/articles/202561599.

Looking forward to hearing from you,

Andrew

Hi, Andrew–

Sure, I’ll upload it. I destroyed the project file already, though, to start fresh. Let me reimport it, do a run, and if I have trouble, get back to you.

Right now I am doing another shorter test run with a smaller set of photos also taken with the GoPro HERO4 Session. Again, it bombed out of initial processing when I changed the HERO4 Session’s setting from perspective to fisheye lens (keeping all the other defaults). I am running it now in perspective mode, where it got past the initial processing with 119 out of 299 images calibrated (39%). This attempt is now in the middle of Point Cloud and Mesh, but I doubt the results will be good due to the low percentage of calibrated images.

Right behind it, I have a test run of iPhone 5S perspective photos to run. We’ll figure this out for sure!

Thanks,

–Dennis.

I uploaded the project to the Pix4D Cloud–will email support now. Thanks!

Tech support has been great helping me with this.

It turns out that the camera profile for the Hero4 Session was completely wrong. I am unable to find the correct specifications for the Session on the GoPro website, so it would require that I contact their tech support.

We have decided to abandon the GoPro Hero4 Session and switch over to a LIDAR sensor for our mapping purposes.

This is an old thread, but I wondered if the correct settings were ever found for the Hero 4 Session.  I ran into a similar problem with it, and it seems the settings are still wrong.

Hi, Thomas–

We never figured it out and ended up returning the GoPro Session and gave up on Pix4D (we didn’t buy another camera).