Support Website Contact Support Blog

forested area disapears when viewing imagery in "Volume" view

I collected imagery with a Mavic Pro of a forested area. I used Pix4D capture to collect imagery. Flying height: 50m. Overlap: 80%. Camera angle between oblique and nadir. Supposed GSD: 1.7 cm. My goal for the imagery had been to estimate the volume of the forested area either directly with pix4D or differencing the height of the trees with a lidar DEM for the same area. There is non-forested terrain around the forested patch.

The forest shows up in the ortho generated in Pix4D but when I go to the “volume” view the forested area is a point-less, black void. Any ideas on if this is because of processing within pix4d or an imagery issue?

My only idea at the moment is to re-shoot flying higher and with more overlap, perhaps changing the camera a angle.

Thank you, Sarah

Hello Sarah,

Has the forest area been reconstructed well in the point cloud and the DSM and orthomosaic?

Could you please send me some screenshots of the area in the rayCloud and in the Volume view to better understand the issue.
Additionally, I would also like to see the quality report of the project.

Regards,


https://drive.google.com/open?id=1dOVqUpIfbeqwgKeEV5N1HERoIT__KYPb 

The link above is to the quality report - didn’t see a way to upload pdf.

No GCPs input yet, just ran rapid analysis with imagery alone.

The survey area over trees resulted in a lot of un-calibrated images. I’m wondering if this could be corrected within mapper or if it’s likely re-flying with different settings could help. 

Thank you very much for your time. I’ve found the support forums helpful as I’m learning pix4d capture and pix4d mapper.

 

Hey Sarah,

Try 0.5 image scale and Alternative calibration method, you may get more images calibrated.

Hi Sarah,

Your idea to fly higher is correct (e.g. 65 - 75 m). Forested areas are challenging for pixel matching as they are more homogenous in texture and trees move even under light winds (forget flying when it is windy!). Increasing the image ground foot prints will raise the possibility to match pixels with solid objects.You are actually lucky, as in this instance you have various man-made structures surrounding your area of interest!

You could also try creating seperate projects for your nadir and oblique imagery and then merging them later…and if you do oblique then you will need more then one direction. For high quality forest point clouds we usually acquire imagery from at least 4 directions (e.g. N, S, E, W).

An example of fusing oblique and nadir imagery. Forest floor occlusion is limited.

Also, there could be a problem with your overlap. Check to make sure that the capture app is using your proper focal length. You can do this by calculating the image footprint size and comparing this to the distance between your georeferenced images. Or by simply adjusting the “projection distance” slider (all the way to the right) in the ray cloud which can give you a visual estimate of your actual overlap.

Adjust slider

 

Estimated visual overlap

 

Hope that helps,

Stu

Hello Sarah,

Indeed, looking at the screenshots and the quality report it is obvious that the images including only vegetation did not get calibrated, creating holes in the point cloud and blurriness in the orthomosaic.

As Stuart mentioned, for trees and dense vegetation, it is more difficult for the software to find enough similarities between overlapping images, and especially if the overlap is not enough it leads to a low number of calibrated images. 

In the following article, you can find more information about improving the outputs of dense vegetation areas: https://support.pix4d.com/hc/en-us/articles/202560159

Please let us know if the result is improved after following the recommendations.

Regards,

 

 

Thank you all very much, just saw all your comments. A day or two after I posted my question I re-flew the area at 70m and two camera angles, almost nadir (pix4d capture doesn’t seem to allow directly down) and at 60%. I set overlap to 90%. I did read the dense vegetation pix4d directions before I re-flew area but didn’t collect coarser GSP (10 cm suggested) because the imagery was for a class which required project imagery have a max GSD of 1 in.   The number of calibrated images increased but not enough to cover the entire forested parcel. 

I didn’t see a way to change the focal length in the dji go app (haven’t researched this though) and the settings options in pix4d capture are pretty limited. I will re-fly and re-process with your suggestions Salim and Stuart.

Thank you again for your assistance, Sarah