Support Website Contact Support Blog

"Failed To Run a Step!" using Processing Area - resolved

Pix4DMapper 2.1.52 64-bit

  1. Do initial processing

  2. Select a processing area in Raycloud

  3. Run Step 2 - Point cloud/mesh

  4. Fails with “Failed to run a step”

Without a processing area selected it can run successfully.

Ideas how to work around this?

More log:

Processing: Processing group group1

Processing: Generating clusters

Processing: Generating clusters

Processing: Generating clusters

Processing: Generating clusters

Processing: Generating clusters

Processing: Generating clusters

Processing: Generating clusters

[Error]: Cluster generator: could not compute valid scores for this project!

[Warning]: Available memory might be insufficient to process this project.

[Error]: Generating clusters failed!

[Error]: >>>Generating clusters<<< failed with error (failed to run a step!)!

[Error]: >>>Generating clusters<<< failed with error (failed to run a step!)!

[Error]: Processing group group1 failed!

[Error]: >>>Processing group group1<<< failed with error (failed to run a step!)!

[Error]: >>>Processing group group1<<< failed with error (failed to run a step!)!

[Error]: Dense Processing failed!

[Error]: >>>Dense Processing<<< failed with error (failed to run a step!)!

[Error]: >>>Dense Processing<<< failed with error (failed to run a step!)!

[Error]: Dense matching failed!

[Error]: >>>Dense matching<<< failed with error (failed to run a step!)!

[Error]: >>>Dense matching<<< failed with error (failed to run a step!)!

Processing: Substep Dense matching finished.

This error went away after adjusting the point cloud and mesh settings, so I am unblocked for now.

Which point cloud and mesh settings did you adjust?

I switched image size from full to half and mesh size from high to medium.

Before switching the settings I attempted running from scratch (Step 1 and 2 with the processing area) and got the same error - but it works correctly after adjusting.  I have not tried going back and trying it again with the previous configuration yet, but I will in the next day or so.

I got it to run by, In Step 2- options,  unchecking  “Generate 3D Textured Mesh” and under the advanced tab unchecking “Use Processing Area”.  I have a feeling that if you don’t define a processing area and have it check to use one, it errors out.  That might be why it says “0 points in the densification area” in the error script.

Hi - I am having the same errors on some of my projects. If i lower the image size from full to half and lower the points generated from high to low, the project works. Unfortunately, i really need as many points as possible, with the highest resolution in the point cloud. 

How can I run this at a really optimized setting? do i need a better computer? more RAM?

 

thanks

Hello all,

Looking at the part of the log that Stephan attached, the issue is that the RAM is not enough to process with very demanding options. When the options are the default ones, processing is successful. So, this assumption is correct. Keep in mind, that for the majority of the projects, the default values are optimal. Selecting more advanced options for the densification and the mesh generation will not necessarily give much better results, but the processing time will increase a lot. 

@ Matt: It looks like another issue related to the processing area. In fact, there was an issue with projects with processing area for which there were tiles that did not contain points. When doing a check on the size of the tiles, processing failed because one tile might be very small or zero. Removing the processing area solved this issue. There is also a bug fix in the latest 2.1.61 version to avoid this. 
Can you please try to process with version 2.1.61 again with the processing are and let us know if the issue persists? If so, it would be interesting to have a look at the log file of the project.

Best regards,

We are using eMotion with an eBee.  When eMotion exports the Pix4d project, it also exports the processing area.  If I delete the processing area prior to processing, step 2 completes. The processing area can always be added back in later if generated from within Pix4D, but for some reason it doesn’t like the one imported in from eMotion.

Hello Matt,

Indeed, eMotion exports a processing area around the model in order to refine the edges of the outputs. If indeed the issue is the one described below, it is just bad luck that the processing area of this project in combination with the size of the point cloud led to some empty tiles and processing failed. However, this is not a generalized issue with the processing option generated by eMotion. In any case, the issue is already solved in later versions.

If indeed the cause of the issue is the one described above, it is just bad luck that the processing area of this project in combination with the size of the point cloud led to some empty tiles and processing failed. However, this is not a generalized issue with the processing areas generated by eMotion. In any case, the issue is already solved in later versions.

Best regards,

Hello, all.

Thank everyone for their suggestions. I’m thinking maybe because I selected my processing area before I corrected my elevation (by clicking two images in two points then reoptimizing), my processing area I selected after Step 1 didn’t have any points inside after I reoptimized. I removed processing area, and it worked. But on second thought, I might have accomplished the same thing by adjusting processing area’s included elevations. Where I’m working, Geoid separation is 90ft +/-. Default vertical inclusion in a new processing area seems to be highest elevation measured +3m (10ft) down to the lowest elevation minus a few feet. So when I reoptimized and whole model shifted 90ft, processing area was up in the air.

Pix 4D mapper Pro 3.0.17

Regards.