[Error]: Merge tiles: failed to load tile!

I am having problems processing my latest project. I have run the process 4 times and always get stuck at Stage 3. Based on the warning prior to the error I suspect there is corrupted data in one of the dsm tiles generated.

I have attached the log file for the project.

Is it possible that there is an image with corrupted data that I could exclude to finish the process?

Any help you could provide would be greatly appreciated. Thanks.

[UI]: Processing Options clicked.

[Warning]: Warning w0032: Results for this project are already generated. By starting the processing again existing results will be overwritten.

[UI]: Processing Start clicked.

Processing: Substep Ortho load pcl started.

Processing: Load point cloud

Processing: Substep Ortho load pcl finished.

Processing: Substep Ortho dsm started.

Processing: Generate DSM

Processing: Substep Ortho dsm merge started.

Processing: Merge DSM tiles

[Warning]: Warning w9020: GDAL Error <1> LZWDecode:Wrong length of decoded string: data probably corrupted at scanline 397

[Warning]: Warning w9020: GDAL Error <1> TIFFReadEncodedStrip() failed.

[Warning]: Warning w9020: GDAL Error <1> O:/Laurel_Hill_Somerset/Laurel Hill Creek Reservoir/3_dsm_ortho/1_dsm/tiles/Laurel Hill Creek Reservoir_dsm_3_1.tif, band 1: IReadBlock failed at X offset 0, Y offset 397: TIFFReadEncodedStrip() failed.

[Error]: Merge tiles: failed to load tile!

[Error]: Merge DSM tiles failed!

[Error]: >>>Merge DSM tiles<<< failed with error (failed to run a step!)!

[Error]: >>>Merge DSM tiles<<< failed with error (failed to run a step!)!

Processing: Substep Ortho dsm merge finished.

Processing: Substep Ortho dsm finished.

Laurel Hill Creek Reservoir.log (1.4 MB)

Hi @jblair

Welcome to our community!

I had a look at the log file.
All the errors are about the failure to merge or load the DSM tiles. I found that the DSM tiles are stored in an external drive in this path.
O:/…/Project name/3dsmortho/1dsm/tiles/Laurel Hill Creek Reservoirdsm11.tif.

Could you process this step 3 on your internal drive C:/ other available internal drives?

I recommend first saving the entire project on a local path by doing the following: Project > Save Project As… > Save project on disk C:/ (for example). Once the project is saved in an internal disk, please re-run step 3.

Let us know if this helps. :+1:

Sincerely,
Rosana (she/her)

I had a chance to run the process last night and it did work. Thank you so much for your help.

It is somewhat strange as I have run bigger projects with many more images and didn’t have this issue. I have wanted to keep the data on the external to avoid taking up too much space on the server or my local drive but I guess it would be best to move the data to the external AFTER processing is complete.

Again, thanks.

Hi @jblair ,

In fact from seeing our customers’ experience in the community, I also sometimes saw that it worked on an external drive. But I guess there is always the risk to run into issues than using the internal disk. Totally understand the reason for using the external drive to save space, but I would say you are right on the spot that it is better to transfer after. :+1:

Sincerely,
Rosana (she/her)

2824 bahrija drone.log (132.8 KB)
Hi

I am having the same problem all of a sudden with all projects i tried to work on, cannot get the orthomosaics. I tried saving project to different internal drives but no success. Log file uploaded. Can you help as I urgently need to work on these projects.

Hi @mark,

Welcome to Pix4D Community!

Please could you tell us which type of drone you are using? We have deployed a hotfix for a similar issue in PIX4Dmapper v4.8.2. Which PIX4Dmapper version are you currently using?

Have a very nice day!

Best regards,

Drone is the DJI Phantom 4.

Pix4Dmapper version 4.5.6 with a perpetual licence

i worked fine so far but all of a sudden this error happened to this project and the ones that followed.

Hi @mark ,

Could you please send us the following?

▸ The quality report (.pdf format): …\project_name\1_initial\report\project_name_report.pdf
▸ The project log file (text file): …\project_name\project_name.log

Best,

2824 bahrija quality_report.pdf (2.2 MB)
2824 bahrija drone.log (1.6 MB)

Please find them uploaded here. Help is greatly appreciated

Hi Mark,

Thank you for the quality report and the log file. :+1:
From the quality report and the log file, I am seeing the images are stored in X:/ disk that seems to be within Dropbox.
One example from the log file.

Image 0 <X:/Geomatix ********* Dropbox/…/…/…/2824 - Bahrija - …/Drone Data/Original Images/DJI_0640.JPG

Step 3 heavily relies on a hard disk, and the only an internal disk is supported. (For more info: Hardware components usage when processing with PIX4Dmapper) Could you please make sure to have the dataset in the internal disk and also ensure there is enough space for PIX4Dmapper to write data in the internal disk?
You can refer to this article to see how many GB you should ensure.
Computer requirements - PIX4Dmapper

Cheers,
Rosana (she/her)

Hi

The folder is called dropbox because prior to having a server we used dropbox andafter migrating data to the server it remained called like that.

The X: and the data folder is on an internal hard drive on our server and all prior projects have been saved in the same location for over a year, so something else must be the issue. Kindly verify.

I have also tried saving on another internal hard drive on the server and the same problem persists.

Dear @Rosana.Lin

So I tried working on a different project which is saved directly to internal Drive X:

Up till step 2 pointcloud creation everything is fine but again is the problem to create Orthomosaic and its DSM contours.

Attached quality report and Log txt. Kindly look into them and advice at your earliest as I am stuck in working on 4 projects required urgently.
_merged_report.pdf (1.4 MB)

For some reason the log txt is not complete till the error given to create TIF dsm but I am attaching anyway
merged.log (23.3 KB)
_merged_report.pdf (1.4 MB)

Hi Mark,
Often times when we see this error we will look at the GPU and what driver is installed. In your case, I noticed that you are running a Tesla GPU. Unfortunately, these are very tricky for us to troubleshoot and I cannot give you full support since these are designed for deep learning and/or datacenters. However, you might want to try updating the driver to see if it helps.