Support Website Contact Support Blog

[Error]: Error saving pointcloud, different number of flags and indices

Any ideas on how to fix this?  I have no idea what the flags and indices are.  The result of this error is that the software will not save the point cloud into different groups, making the point cloud uneditable.

I am having the same issue. I wonder what I am missing? I was trying to remove some errored points to clean up the point cloud a bit but it will not save the changes. It saves the new Point Group but nothing in them

Hello,

Can you please tell us when the error occur? Did you edit the point cloud and then tried to save it? Can you export the modified point cloud?

We had other users with the same issue. It seems that the error message is related to the modification of an old point cloud. Our developers are currently investigating on it. We believe that it will be solved soon, in one of the coming releases.

Regards,

 

Hi there,

I’m also having the same problem. It stopped saving the point cloud after it was regenerated following input of MTPs. The MTPs had some minor triangulation error but managed to stitch the point cloud together as a single block. It was after this that it no longer would save it? I’ve not had this issue before doing the same thing. Are there any further suggestions? 

Hi Simon,

Could you please send us a request so that we can further investigate:
https://support.pix4d.com/hc/en-us/articles/hc/en-us/requests/new

Also please provide us:

  • A screenshot of the error message (if applicable).
  • The quality report: …\Project_name\1_initial\report\Project_name_report.pdf
  • The project log file: …\Project_name\Project_name.txt
  • The project file (.p4d): …\Project_name.pd4

Regards,

Was this issue ever resolved?  I consistently get the error “[Error]: Error saving pointcloud, different number of flags and indices” after trying to save a project with a modified point cloud.  Even if I generate a 3D mesh from the “Process” menu the point cloud comes from the most recent saved version of the project and not point cloud that is shown in the current rayCloud model.

Radio interference ?
Was a big issue with P2V plus

Hi Jim, 

Normally the issue should be fixed since the Preview version 3.1.13, so the latest stable version 3.1.23 should not have that issue anymore. This version is available here: https://cloud.pix4d.com/download/

In case the issue is remaining, please submit a request: https://support.pix4d.com/hc/en-us/articles/hc/en-us/requests/new
And attach the Log file of the project (this is the text file in the results folder of the project). 

Regards