Support Website Contact Support Blog

erreur Z phantom 4 rtk

bonjour, je viens de tester le drone PHANTOM 4 RTK en vue de supprimer le rajout de GCP.

Après plusieurs test, j’ai des erreur de l’ordre du m en XY et de env 50 m en Z.

j’ai lu les différents post et méthode (que j’ai suivi a la lettre) ,mais je ne comprend pas l’erreur ?

il y a t’il d’autre utilisateur qui utilise ce drone et quel est vos retour sur la précision. Faut t’il toujours utiliser les GCP ?

Merci pour votre aide.

PS: j’utilise le service de correction en live de trimble VRSNOW.

Hi @MARIO_laurent,

Our French agent is not available at the moment. Therefore, we will communicate with you in English. We apologies for any inconvenience.

Could you please share with us here the Quality Report of your project? That would help us analyse the problem. Thank you in advance.

Regards

thanks for reply. I solved error in XY, but i want to know how calculate difference hight of geoide up elipsoide for RGF93 CC44?

Hi @MARIO_laurent,

Thanks for the follow-up. Generally, it is not necessary to use the GCPs as the RTK drone is already very precise. However, it depends on the region and the area you’re modelling. Learn more in Do RTK/PPK drones give you better results than GCPs?

I have to say that I’m a bit confused about what type of data you have. Could you clarify the following:

  • The images were acquired in WGS 84, ellipsoidal height. Is it correct? If yes, you should choose Geoid Height Above WGS 84 Ellipsoid equal to 0.00
    image
    and the following options in the Output Coordinate System.
  • Do you have the GCPs? If yes in which coordinate system?

We also described step by step instruction on how to handle the input and set the processing options for RTK data. Please have a look at Processing DJI Phantom 4 RTK datasets with Pix4D especially at the FAQ section where we talk about the vertical coordinate system.

Regards

thanks for reply. I want my Z coordinate in RGF93 CC44 with geoid RAF18.
if possible with 3 GCP , but with my PHANTOM 4 RTK it’s not necessary GCP. How do with no GCP for good résult ?

Thank you for clarifying the situation.

There is no direct way to select the RAF18 geoid in Pix4Dmapper and one of the two workarounds need to be applied:

  • Use GCPs with heights in RAF18. This way the project will be shifted to the position of GCPs and the final results will have the z-values in RAF18.
    Set your output coordinate system to arbitrary and your GCP coordinate system to arbitrary , but leave your collected GCP coordinates untouched.
  • Calculate the offset between GRS80 and RAF18. This can be typically done by tools provided by national surveying societes or governments. Once you get the offset, apply it in the output coordinate system.

You will also see the applied offset in the Quality report.
Example:

As a side note, we recently developed a new software Pix4Dmatic suited mostly for large projects. It also supports different geoid models. See How to work with Geoids in Pix4Dmatic.

Best,

1 Like

I supposed using RTK can provide better results in Z. doesn’t make sense to me use a RTK and still have same errore in Z