Support Website Contact Support Blog

Problems reading heights using DJI drones when entering GCPs measured with rtk

Hello everyone, sorry, I’m using google translate because my english is not really the best. I am having a lot of difficulty in carrying out photogrammetric surveys using DJI drones since the height value extracted by pix4d from the exif data of the photos is the ellipsoid height and not the orthometric one. I state that I use ground targets that are measured by rtk rover.When I upload the photos of the flights, as a first step, I have all in all the ok of the steps (green icon) as a quality report but no 3dg(of course, I haven’t entered them yet ) . When I go to insert the ground control points with orthometric altitude and after confirming them on the raycolud with more than 5 photos each, after having redone the optimization, the error is much higher than the gsd and therefore on the quality report I have a red icon on 3DGCPs. Can anyone give me some suggestions?

Buongiorno Mario,

Thank you for the detailed explanation of your workflow.
Could you ensure that the vertical coordinate system defined for your GCPs and for your outputs is set to arbitrary? You can find more information at the following links:

Pix4Dmapper, unlike Pix4Dmatic, doesn’t support local geoids, therefore one way to define a local geoid as a reference is to set the vertical coordinate system as arbitrary.
Let me know if you have any questions. If you still experience a shift, please attach the quality report of your project. Thank you :slight_smile:

Buongiorno Alice,
sorry for question but…if I use “arbitrary”…wath is the output coordinate system?

Mario



volo_basso_75_report.pdf (238.1 KB)

Ciao Alice…
Flight: free hand fly due the building. camera optic:fixed
I’ve follow your tips but…nothing change : red icon on 3dgpc
Have you any ideas?
Thank’s in advance
Mario

Ciao Mario,

arbitrary systems are used for coordinate systems whose origin, scale and orientation are defined by the user. When you use this option no coordinate conversions are applied and the software will try to adjust the results to the GCPs positions to match them. So in this case, we can say that the output coordinate system will be the same as the one of your GCPs.

I would suggest to use this option only for the vertical coordinate system of your GCPs and your outputs. For the horizontal one, you can still choose to define the coordinate system with one of the available methods.

There is a high projection error on GCP4 (more than 5 pixels) and QCP1 (more than 1 pixel), so please ensure these points were marked correctly on the images.

Please also notice that zoom cameras are not suitable for photogrammetric applications, as having a focal length changing during the acquisition is not optimal. Despite you said that you used the option “camera optic:fixed”, Pix4Dmapper recognized 2 different camera models with different focal lengths and optimized parameters:

  • EXIF ID: FC2204_4.4_4000x3000
  • EXIF ID: FC2204_4.5_4000x3000
    I would suggest using a different camera if possible or strictly ensuring the focal length does not vary during the acquisition.

Ciao Alice,
thank’s for replay.
I will try to recalculate the work following your suggest. Regarding the focal length issue, you are right. The flight I had to do in ATTI mode due to the lack of stable GPS signal and inadvertently I changed the focal length of the optics in 3 photos. Normally I do the photogrammetric flight automatically by setting a lens at 30mm so as not to have too much distortion. This time, however, I could only fly freehand and had to keep the drone under control while it flew to avoid crashes.
Thank’s again
Mario

Ciao Alice,
sorry for the inconvenience. I followed you indication:
output system xy wgs84 utm32, z arbitrary (file capture.jpg). GCP system wgs84 geographic / metric (i’ve made two test with same result) and arbitrary for the z axis (capture1.jpg). Once this is done, the problem is that the GCPs, in the raycloud menu (capture2.jpg), are disabled and I have found no possibility to reposition them. Did I skip that step?This is an automatic flight, done with a fixed lens, which I had done the same day and I needed to have the overall view.
Mario



Hi Mario,

Could you please send us the following from the latest project?

▸ The quality report (.pdf format): …\project_name\1_initial\report\project_name_report.pdf
▸ The project log file (text file): …\project_name\project_name.log
▸ The project file (.p4d): …\project_name.p4d

Best,
Nikoleta

Hi Niloleta,
solved the gcp missing problem : I’ve uninstall and then reinstall the system.My be some registry failure. Now,I’ll remake the job.
Mario

Ok, now the icons are green while that of the 3DGCP is yellow but within the limits (unfortunately the GCP4 gives problems but I already knew it at the start). However I have a rms of 0.03 … more than happy! So if I understand correctly, in this way the X and Y coordinates are georeferenced correctly, while on the z axis we refer to the GCP value. Right?

Hi Mario,

I believe your understanding is correct, if you use GCPs in your project the the outputs should align with the GCP position.

Let us know if you have any other questions regarding the project,