Support Website Contact Support Blog

DJI Phantom 4 smart controller

Does anyone in the community or at Pix4D tech support know how to upload the Pix4D mapper software onto the older model Phantom smart controller as I have tried and get an “incompatible” software warning. Thanks for any feedback and tips.

Hi Lewis,

To be able to help you efficiently I would need some clarifications about what you are  tring to do here:

  • What is your exact configuration? (drone, camera, mobile device). I guess you are using a P4P+ with the integrated screen, am I right? You can find back the supported configuration by Pix4Dcapture here.
  • What are you exactly trying to do? Using the DJI smart controller with a P4P? In this case, it will not be possible as the DJI Smart Controller is not compatible with the P4P. Are you maybe talking about the DJI CrystalSky?
  • What is your workflow to use your drone with Pix4Dcapture? Can you connect properly to your drone?
  • Would it be possible to send us relevant screenshots of the issue?

Also, don’t hesitate to look at our basic checks and troubleshooting steps as it will solve most of the issues that can be encountered by users if properly followed.

Best regards,