Support Website Contact Support Blog

Disabling orthomosaic creation during step 1

Hi everyone,

I’m wondering if I have a bad interpretation of Step 1 configuration parameters, or if this is really a bug.

To save some processing time, I always uncheck the option “Generate Orthomosaic Preview in Quality Report” in step 1 parametrs. However, monitoring the processing tasks, I still can read “Generate Quality Report (orthomosaic)” in the progress bar when Pix4D is close to conclude step1.

it seems to me that Pix4D disregards that parameter and always generates the orthomosaic for the quality report in step 1 (even if it is not actually included in the PDF). This is really annoying, as it requires considerable time to process, especially in large projects.

Is my understanding correct? Please advise. I am currently using Pix4DMapper version 4.4.12

Thank you

Hi,

I made a test with Pix4D Demo project, and I can see that there is a difference in the way we are generating the Quality Report or not. However, maybe you can also share with us the files of your project, and we investigate the issue you described one more time.

Best regards

Hi Beata,

Sure, I can share some of the project files if that is necessary. However, what I am reporting (apparently) happens to any Pix4D project, so I’m sure you will be able to simulate it on your end. It is just easier to note when you are processing large projects, as Pix4D takes longer to conclude step 1 as it (potentially) wastes time creating an orthomosaic when I have configured it not to do so.

But, anyway, please tell me what files do you need from this particular project and I will see if I can share them (they belong to a client and I cannot share without asking for his permission). I must advise, however, that it contains more than 2000 photos.

Looking forward to hearing from you.

Thanks

Hi,

It would be perfect if you could share two .log files with us of this large project with Generate Orthomosaic Preview in Quality Report option enabled and disabled, and Quality Reports. You can upload those files to the dedicated OneDrvie folder here.

Thank you in advance! :wink:

Hi Beata,

I have attached a log file related to a project in which the option “Generate Orthomosaic Preview in Quality Report” was disabled. I read through some parts of the log and I do see things like:

[2019.06.18 09:16:53][15%RAM][0%CPU][Info]: Generate orthomosaic for report = <no>

But I also see things like:

[2019.06.18 14:08:16][32%RAM][11%CPU][Info]: Report: orthomosaic size 1872x1249@0.921871m / 59930x39976@0.0288085m.[2019.06.18 14:10:09][32%RAM][7%CPU][Processing]: Generate Quality Report (orthomosaic) [group1]
[2019.06.18 14:10:09][32%RAM][7%CPU][Info]: Generate Quality Report (orthomosaic) [group1] [0/1] elapsed 001ms …[2019.06.18 14:22:58][28%RAM][40%CPU][Info]: >>>Generate Quality Report (orthomosaic) [group1]<<< done in 12m:49s:097ms / 12.8183 min.

So I wonder if it is just my impression or the software is really ignoring the option to not generate the orthomosaic in the quality report. Please see if you can clarify the issue.

Thank you

Hi,

I confirm, there is an issue. Thank you very much for bringing it into our attention. Our developers will fix it in the next Pix4Dmapper Preview. If the processing takes you too much time, please use Pix4Dmapper 4.3.33. 

Please also follow Pix4D Desktop preview and technical release notes to get notifications about the new release. 

Our apologies for any unintended inconveniences.

Best regards

Hi,

I confirm, there is an issue. Thank you very much for bringing it into our attention. Our developers will fix it in the next Pix4Dmapper Preview. If the processing takes you too much time, please use Pix4Dmapper 4.3.33. 

Please also follow Pix4D Desktop preview and technical release notes to get notifications about the new release. 

Our apologies for any unintended inconveniences.

Best regards

Hi Beata,

I’m glad it helped. Thank you for your support.

Regards