Support Website Contact Support Blog

[Desktop][Pix4Dmapper]"Error e1001: Could not replace the current camera model with the edited one." when trying to switch to created/edited camera module

Hi, first time user here.

I’ve been trying to test this software with photos taken with the 14.4 MP kernel camera from Mapir. It didn’t have an existing entry so I tried to create one, I followed the guide for a fish eye lens found here:

https://support.pix4d.com/hc/en-us/articles/202557009-How-to-calibrate-a-Fisheye-Lens-Camera

I used both manually entered entries and the values autogenerated from the EXIF data. I saved the database after all the necessary values were filled in, but when I tried to switch to the newly created (or edited) entry, it spits out the above error code/message. when I go back to reselect edit the camera module it spits out another error message: 

[Error]: Error e0024: The parameters of the camera model are not valid. Select another camera model or edit the current one. Error: Set the pixel size > 0micron.

 

as I’m new to this software, I’m fairly sure this is user error, but any ideas what’s wrong?

Hi Mark,

Indeed, there is no 14.4 MP camera in our database. I assume you captured images with this camera: https://www.mapir.camera/products/kernel-14mp?

When a camera is not in our internal camera database, the software retrieves the necessary camera internal parameters (sensor width, pixel size, etc.) from the EXIF tags of the images. It is only if a camera model parameter is not identified in the EXIF that you will have to enter it into the Camera Model Editor manually.
Didn’t the EXIF tags contain all the necessary information regarding the camera parameters in the EXIF tags of your images? To learn about the EXIF tags read by Pix4Dmapper, check out this article.

If there are no EXIF tags Pix4Dmapper can exploit, you will need to calibrate your camera yourself. We recommend to follow the instructions in these articles:

I hope this helps! Let us know if you have any questions.

Hi.

I am having the same problem as Mark with the same camera.  Did you get any joy Mark - what were you able to do?

Rhea - I can’t calibrate the camera as per those instructions as I can’t get beyond this stage of loading up the images as the "next’ button remains greyed out.  Here are some screenshots of what I did (I estimated properties from exif, which were correct and did not have to be changed).

Hi Lance,

I am not sure why there are three different cameras in your project.

If you could open a support ticket, we could investigate further.

For now, since the cameras are the same, I would assign all of the images to one of them

To do that, please select all of the images, and click with the right mouse button into the camera model and select the camera:

 

 

Please let me know how it goes.

Thank you very much.