Support Website Contact Support Blog

DJI Phantom 4 RTK camera model

I ran into a problem that I wanted to share because it took me a long hours to discover the problem.

Seems, that P4RTK has different camera models and even latest Pix4Dmapper (4.5.6) does not have all of them in database.

When I imported pictures, Pix4D automatically recognized cameral model P4RTK, but after initial processing calibrated camera computed positons some of them were wery wrong locations and after final processing the point cloud was very stretched / very wrong. I did all other tricks what advice I found - Keypoints half image size, matching geometrically verified and calibration all prior etc. Nothing helped. Last thing I looked camera model parameters, imported from EXIF and wow - this is where the dog is buried.

From Pix4Dmapper 4.5.6 database


And from EXIF

Now the results are perfect :slight_smile: !

Hi,

Thank you for sharing your insights with us.

As you already pointed out, the initial values from the manufacturer (EXIF) and the ones in the Pix4Dmapper internal camera database are not identical.

It is a general practice that we refine the parameters in order to take into account some systematic errors that would happen when using only the EXIF parameters. Since the EXIF only contains approximate parameters the camera optimization would typically drift toward other parameters (similar for all P4RTK cameras) when using them for processing.

Every camera is different and the parameters can slightly vary and therefore also the parameters in the Pix4Dmapper internal camera database are approximate in the end. Cameras are sensitive to vibration, temperature, etc., and the software will, by default, optimize the internal parameters for each project starting from the initial parameters from the database.

However, we are happy to hear that your customized camera model with the EXIF values worked. As long as you are savvy enough to calibrate your own camera model with the desired values, I don’t see why you should not apply this method.

Cheers,
Teodora

Thank you for the feedback.
For me it is just surprising that the same cameras of one manufacturer are with different parameters,
previously i used several different phanton 4 and phantom 4 pro’s and no such problem, pix4d database exactly matched.

Are you using the same camera settings during acquisition as the last image datasets that were successfully processed? Could you share a quality report of the project where you were using the parameters from the Pix4Dmapper database?

With EXIF used parameter report and from database used parameter report:
200319_Koidula1417_report.pdf (245.8 KB)
200319_Koidula1417_2_report.pdf (216.3 KB)

Hi,

Could you upload the image dataset on our OneDrive, so that we can take a better look?

Best,
Teodora

look likes I have encounter this problem too