Desktop Pix4d Mapper: Can't get camera to calibrate. Automatic tie points staying red.

I have a camera with a LOT of automatic tie points that are all RED.  I added 28 manual tie points, spread over the whole image, that are all yellow.  It still won’t calibrate.  Any ideas?  Do I need to do something after creating the MTPs, and before calibrating?

Hi Darren,

Here you can see the procedure for calibrating an uncalibrated image: 

How to manually calibrate uncalibrated Cameras in the rayCloud

I admit that it is a time-consuming procedure and I would not recommend it for 1 image. 

Given that your dataset has good overlap, having 1 uncalibrated image (or a couple of them :blush:) should not make any difference in your results. 

Let us know your thoughts.

Thanks for the reply.  I have created lots of MTPs and connected lots of points, as the article suggests.  Is there another missing step between that and calibration?  Do I need to rematch and optimize, for example?  Or should I just keep adding MTPs, and at some point the image will suddenly be able to be calibrated?

It’s one image in the middle of the last row of pictures on the edge of a site. It seems to be causing the rest of the row to come in as another block, so I would like to get it to calibrate.  Unfortunately, I do not have any more access to the site, to get additional photos.

Hey Darren,

Have you tried 0.5 image scale and Alternative calibration method? Moreover, your images may be over or under exposed. Are you imaging snow, water, bare soil or high-dense vegetation? Because due to homogeneous texture of those images it is difficult to calibrate them.

1 Like

Can anyone answer my question about the procedure?  Do I need to do anything after creating the manual tie points, and before calibrating the image?  Or will the calibrate button just suddenly work once I have added enough points?

Hey Darren,

You should hit the calibrate button then re-optimize and re-match. Furthermore you need at least 20 points before you can calibrate the MTP’s.

You may take a look at the following link:

1 Like

Hi Darren,

After adding matches (Connect to Τie Point ) and/or Manual Tie Points, you should Press the  Calibrate button to calibrate the camera. The button gets enabled when:

  • The image has at least 20 inliers.
  • All manually marked points (MTPs) are inliers.

For more information about what an inlier is, please have a look at the above-mentioned article.

Then you need to click  Process > Rematch and Optimize.

As Selim commented, it would be interesting to understand why the image did not get calibrated in the first place and whether you used the right processing options. Feel free to upload your quality report (or screenshots of it) if you would like us to have a look :slight_smile: