Support Website Contact Support Blog

Data lost after GCP reoptimize

 Hello,

I’ve seen a post similar to mine but I couldn’t resolve the problem with it. Therefor I post a new one with new information. So…

I run process one and 2, I manually add GCP to the project and they are displayed in green.

I then click on reoptimize and…here what I get

 

A black screen with point clouds and group that disapear. 

 

Could someone help me? My client is waiting for me to give him the curve lines…but I cannot do anything after repotimize.

Last but not least…i Cannot generate a quality report…

Hi there

 

You should add GCP’s before or after step 1. If you want to do it before step one use the basic editor. If you want to add them after step 1 you can do it in raycloud. If you add GCP’s after processing step 2 you will lose the calculated point cloud.

https://support.pix4d.com/hc/en-us/articles/202560039-How-to-add-import-GCPs-in-the-GCP-MTP-Manager

https://support.pix4d.com/hc/en-us/articles/202560769-How-to-mark-GCPs-in-the-rayCloud

2 Likes

I will try this. Thank you VERY MUCH. I will let you know.

So if I understand well:

  1. Step one only.

  2. Add GCP with ray cloud.

  3. Reoptimize.

  4. Generate step 2 and 3?

Yep. That’s the right workflow

1 Like

How did it go…??? Here the answer :wink:

I first choose the coordinate my client was supposed to use to add the GCP with ray cloud…

After adding the point I saw this: a green line that pop out of the screen forever…I m thinking the client didnt give me the correct informations… (btw where can I check the system he gave me to be sure he is correct? for example his coordinate point were:   for somewhere in Switzerland…)

 

As it seemed out of line, I choose arbitrary coordinate point and got this: it seems all my point are correctly placed that way… 

I reoptimize and once again… I’ve got that black screen where I cannot click on tie points. This time there are error message…I had already done GCP marking and stuff like that…but I m lost now. Any help would be VERY appreciate. Thank you.

Could you share the dataset and GCP coordinates? I could take a look at it 

Thank you so much for the help…I m getting nervous as my client is pressing me (i’m trying since wednesday to do that). Sorry but what do you mean by dataset? I went on site, we marked the GCP, he wrote numbers and said he’d send them to me…here they are:

 

I’m going to need the pictures also. Can you upload them to e.g Dropbox or OneDrive?

I’ve upload one picture. And THANK YOU for the help…

 

https://www.dropbox.com/s/gecofqg133mrt3r/Vignelz%2000001%20Drone%20Deploy%20%2827%29.JPG?dl=0

For the all set it’s gonna be in 45min on google drive

Reply to this thread when the upload has finished so I’ll get notification via email.

here the link of the pictures

https://drive.google.com/drive/folders/1fsSL70ar8fi8N7ntthbVS5UazmK2sJSG?usp=sharing

Downloading. What is the correct coordinate system?

good question…on the drone it’s taken by a mavic so I suppose it’s WGS84.

 

For his coordinate system he said the CHTRF95. But when I enter his coordinate on internet, it says it’s out of Switzerland. When I use these in pix4D, it’s where I ve that long green line.

So I converted from MN95 to WGS84 with this https://www.swisstopo.admin.ch/fr/cartes-donnees-en-ligne/calculation-services/navref.html

After that, I’ve tried to locate the area with this website  and it worked. https://www.ornitho.ch/index.php?m_id=48

 

That’s the correct output coordinate system

edit you GCP’s so that it looks like this:

Next time you should’t make a straight line with GCP’s. I’ve marked the map with places where I’ve placed them.

Man you’re my Saver…I ll try it! How did you figure out which system it was???