Support Website Contact Support Blog

crash, step 2, densification

Why does it crash during point densification, 3.5 hours in, group 1.
project is 800 25mb jpg images.
400 gb free space on C drive.
Problem is when it crashes the log goes with it so there is no record of what happened.

Any ideas? My last project was 1,100 same size images with no problem.

Thanks,
Jamie

Hi @jamie,

Well if you have reached the second step the *.log file should have been generated.
It should be located there:
…\project_name\project_name.log

Could you also share with us the quality report?
…\project_name\1_initial\report\project_name_report.pdf

My guess is that you where running out of RAM or CPU since these components are the most used during step 2.

In order to troubleshoot, we need the *.log file otherwise we will not be able to understand what is going on.

Best

Thank you for responding Marco.
I’ve attached the report and log below. Thanks also, now I know where to find the log now even when p4d closes. Since I’ve tried processing this file several times the log was too large to upload whole. I truncated the log, deleted several days prior to yesterday and a lot of the repetitious image loading lines. I left a blank line where I deleted the repetitious lines in step 1 and another where step 2 starts.

I originally ran step 1 with the image GPS exif data. Then cleared the image exif data (my GPS is 1 hz and traveling 11 meters per second so not accurate), added 3 GCPs and a processing area of about half the project then reprocessed. That appeared fine so continued to step 2 and 3. It appears to me to fail after densification.

I so appreciate your help.

report.xml (18.9 KB)

log to marco 2 13 20.txt (160.8 KB)

Hi,

What do you mean by "

Do you mean that you ran step 1 and then you go in the image and modify the EXIF?
This is absolutely not recommended.
I would recommend you to follow this article:


I could not spot any obvious error in your log.
But if you clean the EXIF, it could be the source of the error.

Best

Thanks Marco, I’ll try it without clearing the exif data. In the past I have found projects georeferenced only to GCP are more accurate in absolute terms rather than including my gps reference. I think the gps, which shows 1 to 3 images taken from the same lat long, competes with the GCPs for the final position. Is this feasible?

Thanks,

Jamie

Well, this statement surprises me. It could be true for some projects though.
However, during the first step the calibration is based on the images’ geotags meaning that our algorithm will use the image geolocation to reconstruct the model.
Processing images without geotags and then georeference it using GCPs is feasible.
But you should not clean the EXIF after step 1 since they have been used during step 1.
Good luck,
Best

Marco, I eventually had success with the previous 800 image project.

Now I have a project with 1022 images which, after a couple tries, was successful with a processing area of the south 1/2, about 600 images. Used exif data and some poor gcps added after step 2 and re optimized. Due to the lousy georeferencing I find I can get improved results taking the geo TiFF into Global Mapper and registering the imagery to some road center-lines from the customer.

Further attempts to use that same project failed at step 2 no matter how I tried to process. I had originally thought I could simply change the processing area to the north 1/2 and reprocess. It failed several times. I tried splitting the project with failures.

Now trying a fresh approach. I’ve started a new project utilizing images for the north half only. 686 images. Using exif data and no gcps ( They do not exist with any accuracy).
I have a failure at step 2 with message: the instruction at 0x00007ff89f88a839 referencing memory at 0x0000025409560000. The memory could not be written.

I seem to have several types of failures at step 2 on all these projects. I’ve had perfect success two times with acceptable gcps available, both large data sets. But that is after about 20 efforts.

My computer has 32 ram, 397 GB free ssd drive C space, and 1.1TB free on drive I where the imagery and projects reside.

Here is a link to the log and quality report for latest project.

https://spaces.hightail.com/receive/qkVFQbuUdT/amFtaWVAd3lvbWluZ2Flcm9waG90by5jb20=

Thank you.

Marco, I realized reading my post, at second line I put “after step 2” that should be “after step 1”

Marco,
since my last post, reloaded p4d, updated windows 10, scanned and optimized disk drives, got rid of some trash.
Failed again. Quality report, p4d file and log here:

https://spaces.hightail.com/receive/FDyDzO5XjP

now running it again with 3 gcps and the exif data cleared.