Support Website Contact Support Blog

Connection Problems with Ctrl+DJI Matrice 100

I have a DJI Matrice 100 but I cannot even connect Ctrl+DJI to it… the latest firmware is installed and the device I’m using has the latest Android version possible (8.1.0), kernel version 3.18.79.
Already allowed every extension possible but still, the app seems to crash and disconnects.
Also, there is no other app running in the back while I’m trying to connect to Ctrl+DJI.

Is there anything I can do to solve this issue? 

Thank you
   

Hi Sergio,

Can you tell me what camera are you using?
Have you been able to connect to this drone in your configuration and make an images acquisition before using Pix4Dcapture? Has the issue come with a drone firmware update or software update?
When you say the app seems to crash and disconnects, do you mean that the app stops suddenly or it is not able to connect to the drone?

I would suggest you go through the following steps of our basic checks and troubleshooting article:

  • Make sure that you are updated with the latest Pix4Dcapture and Ctrl+DJI apps
  • The drone manufacturer’s original app is not selected as default: (Android) How to change default app when connecting to the drone
  • The correct drone and camera are selected in the settings of Pix4Dcapture.
  • Ensure that basic features work properly in the drone manufacturer app (Basic features are working properly (Manual takeoff and flying, Live video feed of the camera, Manual picture triggering).
  • Force quit Pix4Dcapture and reopen it: (Android, iOS) How to force quit an app.
  • Restart your mission from scratch. To do so, close and force quit the app, disconnect the cable from the mobile device, turn off the remote controller and the drone. Then switch on the drone and the controller, reconnect the USB cable and open Pix4Dcapture. On Android, launch Pix4Dcapture from Ctrl+plugin.
  • If possible, try another iOS or Android mobile device.
  • Try another USB cable.

Let me know if it may have solved your issue.

Best,

Hi Gaël,

 

The camera I’m using is the Zenmuse X3. In the past, I’ve always used other softwares, including DJI Go and Precision flight. Never had any similar problem with those apps, only when I installed Pix4Dcapture and Ctrl+DJI. Referring to the crash issue, I meant the impossibility of connecting with the drone.

Already followed all the procedures listed and tried another Android mobile device. I’ve done the same procedures and allowed the same extensions and…strangely (or not) it connected immediately… Still, cannot figure it out what is causing the connection problem.

Thank you for your help,