Support Website Contact Support Blog

camera not supported - Phantom 4 RTK

Hi i’m new to Pix4d ,
try to upload images to the Pix4Dmatic and i get the camera not supported message
i am working with the Phantom 4 RTK - and it appear in the documentation as supported.
what am i missing?

Hi gis1,

Thanks for reporting the issue. Could you please share an image of your project? You can click on the upload button when writing your reply in this thread and you’ll be able to select an image on your device. I’ll download it and check if I get the same error on my version.

Are you on Windows or macOS? Please specify which OS version too.
Thank you.

Hi pierangelo,
I’m on windows - i attached a image for the project

thank!

Thanks for sharing an image!

The resolution of the image is at 2432x1824 but we only support the highest resolution imagery 5472x3648 for the Phantom 4 RTK in Pix4Dmatic. This should explain the error at importing.

The reason why we only support the higher resolution imagery is that it results in better results during processing. Was there a specific reason you selected this lower resolution?

You can see the supported resolutions for the different camera models in the EXIF name in the supported camera documentation here: https://support.pix4d.com/hc/en-us/articles/360037744571-Which-cameras-are-supported-in-Pix4Dmatic

Do you have another dataset with Phantom 4 RTK images at 5472x3648 resolution? If yes, please try and let me know if it worked.

Interesting.
We used this resolution because of requirements in a different software for processing the data, i will collect a new set of images and try.

thanks!

Ok, keep us posted!
Out of curiosity, what other software requires such a small resolution?

We used DroneDeploy and the Bently contextcapture both recommended that.

I will update on the new images :slightly_smiling_face: