Support Website Contact Support Blog

Android + pix4d + dji go connection problem

Hi all.
I’m using Samsung s6. So far everything was working when i was using dji go.
After installing pix4d (3.3.1) and ctrl+dji i’ve a problem. When turning on the drone controller pix4d capture launches automatically. But when i wanna open dji go it shows that there is no connection. Ctrl+dji shows connection…
How can I open dji go te change f.e. camera settings?
Thanks.

Hi,

It is important that the DJI GO does not run at the same time as Pix4Dcapture. The SDK (what allows the communication between the drone’s firmware and an app) cannot interact with both at the same time. Therefore it is essential to make sure DJI GO is not running in the background especially after connecting the device to the drone. On Android, you should check that this app is not selected as the default app when connecting. If needed, force the app to stop.

How to force quit an app: https://support.pix4d.com/hc/en-us/articles/209626486

On Android, it can also be needed to change the default app for flying since it should not be DJI GO when running Pix4Dcapture: https://support.pix4d.com/hc/en-us/articles/212300043

The same applies the other way around. If you want to use DJI GO, it can be necessary to force quit Pix4Dcapture and to make sure Pix4Dcapture is not the default app when connecting the drone.

Regards,

I am new to drone surveying. I am using a Motorola Moto G with Android version 4.4.4  I had been using DJI Go and then installed Pix4DCapture to plan and fly sample missions.  This worked beautifully for one mission. I calibrated the Phantom 3 Pro using DJI Go, closed that app and opened Pix4DCapture, flew the mission and it worked beautifully.  Today, I tried the same thing and when I launch Pix4D, it says that DJI Go is running in the background. I forced the app to close; I shut down the phone and restarted only using Pix4D.  Now, neither application is working.  DJI Go says it isn’t connected to the drone, though the controller works.  Whenver I launch DJI Go, the Pix4DCapture app then automatically launches as well.  If I start Pix4DCapture, it won’t start a mission because it says that DJI Go is running even when I have shut down and restarted the phone and tried to force DJI Go to close.

Do you have any suggestions? I don’t want to have to use two phones! Thank you very much for your help.

Hi Jean,

Can you please check if the DJI GO is set as a default app when you are trying to establish the connection with the drone. If another app, e.g. DJI GO, was used in the past to fly the drone and the user tapped Always, there is a conflict and Pix4Dcapture will not be able to connect to the drone.

Have a look at this step-by-step instructions on how to clear default app: https://support.pix4d.com/hc/en-us/articles/212300043

After that you can connect the device to the controller and select the Pix4Dcapture which should allow you to use the app as intended.

Regards,