Support Website Contact Support Blog

Android Camera View Issue (P3P)

Hi,

I am having an issue with my android devices in viewing the camera view in the Capture App. 

Hardware/Software Details:

DJI Phantom 3 Pro

Samsung Galaxy Tab 4 (Android 4.4.2)

Samsung Galaxy S6 (Android 5.1.1)

Capture App (2.0.8)

I do not believe it is an issue with the P3P as in the DJI GO App I have no issues with the camera view. I am still able to fly missions successfully, just cannot get the camera feed. Ideally I would like to be able to fly free-missions with the camera view so that I can see what I am taking photos of and be able to fly the P3P.

Any help is much appreciated.

Cheers

Tested it on another device (Samsung Galaxy Tab S2 7.0 - 4.4.2 Version Android) and the camera view worked. Unfortunately I still need a fix for the Tab 4 as I would rather not have to go buy another S4 as the one I tested on is a colleagues personal device.

If any further information is required please just ask.

 

Thanks 

Hi,

I’m also using Capture with my P3P.

What do you mean you have issues with the camera view?
If you select the FREE FLIGHT MISSION option from the home menu, and then click the camera tab, you cannot see what the drone’s camera can actually views?

Hi,

Yes that is exactly correct. Not only can I not see what the camera actually views in the Free Flight Mission option but also in the Grid Mission. 

Hi all,

The new DJI SDK 3.0 is being integrated to Pix4Dcapture.
Our Capture team is currently working on it.
Therefore a new version will be released soon and will probably fix that issue that other users also reported.

Any Pix4Dcapture update is posted here: https://support.pix4d.com/hc/en-us/articles/hc/communities/public/questions/203121499
You can follow this post to be notified when a new comment is written. Click the “Follow” button on the top right corner of the post to follow it. Note that you need to be logged in with a Pix4D account to click this button.

Best regards,

Hi

Still having problems especially with free flight where I’m getting no feed what so ever

tablet: Sams SM T280

android: 5.1.1

pix4d vers: 3.5.1

 

Hi,

Could you please provide more info regarding the drone and camera you are using to fly a mission with our app?
Unfortunately the camera feed does not work for some configurations.
Also do you have the latest DJI firmware installed on the DJI drone?

Regards,

dji firmware is 1.9.60 and 3.0.1 for the remote (updated simultaneously and successfully). Camera is stock phantom 3 prof. Camera view is only working during grid missions and requires a flick between map and camera view for the live feed to start, always. 

Regards

The latest firmware version is 1.10.90 and came out on 29.11.2016: http://www.dji.com/product/phantom-3-pro/info#downloads
Could you perhaps upgrade first before giving another try?

Regards,

Thank you for the suggestion, but I will not be upgrading to that version, since it is not clear -yet- what sort of an upgrade it is, if it is one actually! Many people have ran into problems with the new version

Regards

I am also now having this issue.  A few days ago I had ‘DJI Internal Error’ issue and couldn’t even fly missions…now I can fly (I have only tried a small test grid so far).  The RPA flew fine (P3P) but there was no camera feed.  Post flight analysis shows that it took photos fine but I had no way of seeing that during the flight.  (Clicking from map to camera icon gave me a black screen).

Anyone else still having this issue?

@Brian, there are other users reporting “DJI Internal Error” issue in this post HERE.

Could you give us more information about the video feed not working? There were some users experiencing a similar issue after they updated the firmware of the drone so we are suspecting that it might be related to this. We checked few .log files but were not able to find the issue on our side.

Best,